summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/g-sorcery')
-rw-r--r--app-portage/g-sorcery/g-sorcery-9999.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/app-portage/g-sorcery/g-sorcery-9999.ebuild b/app-portage/g-sorcery/g-sorcery-9999.ebuild
deleted file mode 100644
index f511341ccb9a..000000000000
--- a/app-portage/g-sorcery/g-sorcery-9999.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=(python3_6)
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="framework for ebuild generators"
-HOMEPAGE="https://github.com/jauhien/g-sorcery"
-SRC_URI=""
-EGIT_BRANCH="master"
-EGIT_REPO_URI="git://git.gentoo.org/proj/g-sorcery.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="bson git"
-
-DEPEND="bson? ( dev-python/pymongo[${PYTHON_USEDEP}] )
- git? ( dev-vcs/git )
- sys-apps/portage[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-PDEPEND=">=app-portage/layman-2.2.0[g-sorcery(-),${PYTHON_USEDEP}]"
-
-python_test() {
- PYTHONPATH="." "${PYTHON}" scripts/run_tests.py || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- doman docs/*.8
- docinto html
- dodoc docs/developer_instructions.html
- diropts -m0777
- dodir /var/lib/${PN}
- keepdir /var/lib/${PN}
-}