summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gemato')
-rw-r--r--app-portage/gemato/Manifest2
-rw-r--r--app-portage/gemato/gemato-20.5.ebuild (renamed from app-portage/gemato/gemato-16.2.ebuild)29
-rw-r--r--app-portage/gemato/gemato-9999.ebuild28
-rw-r--r--app-portage/gemato/metadata.xml7
4 files changed, 41 insertions, 25 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index d866b5780118..fc6ef1cb2a13 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1 +1 @@
-DIST gemato-16.2.tar.gz 80178 BLAKE2B c973c36bb1277d07618ba8d90f7d6820508d78aedae200f0678c8b2e1dde38e3b7f4d7dc24791dedb9c88791d3b71711c9bdeb749b5fc091a20aa87f71ad70d3 SHA512 9d59ba360afaf237e47c5ded0e5bc29ec44d5b1d73eadadc19ff834a1966e1e620da258eb7a1b6afbff5c66cbd7e39454fd5920f2f82fc510c2f8836c0b80462
+DIST gemato-20.5.tar.gz 88598 BLAKE2B dadbdd0275b6a79bb1c288d85ccb41600715c5e582b0d427a7fca5f08a8390200929b3de921bb7bd56f4a155fd9d979baaccb29a75c119c418c3ab62202f2856 SHA512 427e198b0630a18f219739dc093ddd0752a9b9871cd4ebf78b035c315bb49e4a5a639811d5fc26a17446c29eeea133e5cb97bb38fe89e2f74a6a320fd9bf5f0a
diff --git a/app-portage/gemato/gemato-16.2.ebuild b/app-portage/gemato/gemato-20.5.ebuild
index 206c761c09ca..900b3fb64110 100644
--- a/app-portage/gemato/gemato-16.2.ebuild
+++ b/app-portage/gemato/gemato-20.5.ebuild
@@ -1,34 +1,41 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
PYTHON_REQ_USE='threads(+)'
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Stand-alone Manifest generation & verification tool"
-HOMEPAGE="https://github.com/mgorny/gemato"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
-IUSE="+gpg tools"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="+gpg pretty-log tools"
RDEPEND="
gpg? (
>=app-crypt/gnupg-2.2.20-r1
dev-python/requests[${PYTHON_USEDEP}]
- )"
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
BDEPEND="
test? (
>=app-crypt/gnupg-2.2.20-r1
- >=dev-python/pytest-5[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/responses[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
index 5d6009149ea0..9f78bf067f39 100644
--- a/app-portage/gemato/gemato-9999.ebuild
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -1,35 +1,41 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
PYTHON_REQ_USE='threads(+)'
inherit distutils-r1 git-r3
DESCRIPTION="Stand-alone Manifest generation & verification tool"
-HOMEPAGE="https://github.com/mgorny/gemato"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/mgorny/gemato.git"
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
+EGIT_REPO_URI="https://github.com/projg2/gemato.git"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS=""
-IUSE="+gpg tools"
+IUSE="+gpg pretty-log tools"
RDEPEND="
gpg? (
>=app-crypt/gnupg-2.2.20-r1
dev-python/requests[${PYTHON_USEDEP}]
- )"
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
BDEPEND="
test? (
>=app-crypt/gnupg-2.2.20-r1
- >=dev-python/pytest-5[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/responses[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest
diff --git a/app-portage/gemato/metadata.xml b/app-portage/gemato/metadata.xml
index eb67cd16de91..aa7988a48ee7 100644
--- a/app-portage/gemato/metadata.xml
+++ b/app-portage/gemato/metadata.xml
@@ -9,12 +9,15 @@
<use>
<flag name="gpg">Install dependencies needed for OpenPGP
signature verification support</flag>
+ <flag name="pretty-log">Pull <pkg>dev-python/rich</pkg>
+ to enable pretty logs</flag>
<flag name="tools">Install additional utilities (benchmarks,
hash testing tools, fast Manifest generators)
to /usr/share/gemato.</flag>
</use>
<upstream>
- <bugs-to>https://github.com/mgorny/gemato/issues/</bugs-to>
- <remote-id type="github">mgorny/gemato</remote-id>
+ <bugs-to>https://github.com/projg2/gemato/issues/</bugs-to>
+ <remote-id type="github">projg2/gemato</remote-id>
+ <remote-id type="pypi">gemato</remote-id>
</upstream>
</pkgmetadata>