summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/genlop/genlop-9999.ebuild')
-rw-r--r--app-portage/genlop/genlop-9999.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/app-portage/genlop/genlop-9999.ebuild b/app-portage/genlop/genlop-9999.ebuild
index fe9a088ea8af..a17ddee040e7 100644
--- a/app-portage/genlop/genlop-9999.ebuild
+++ b/app-portage/genlop/genlop-9999.ebuild
@@ -1,13 +1,20 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit git-r3 bash-completion-r1
+inherit bash-completion-r1
-EGIT_REPO_URI="https://github.com/gentoo-perl/genlop.git"
-DESCRIPTION="A nice emerge.log parser"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl"
+DESCRIPTION="Nice emerge.log parser"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl https://github.com/gentoo-perl/genlop"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/gentoo-perl/genlop"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
LICENSE="GPL-2"
SLOT="0"
@@ -15,7 +22,8 @@ SLOT="0"
DEPEND="
dev-lang/perl
dev-perl/Date-Manip
- dev-perl/libwww-perl"
+ dev-perl/libwww-perl
+"
RDEPEND="${DEPEND}"
src_install() {