summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gpyutils')
-rw-r--r--app-portage/gpyutils/Manifest2
-rw-r--r--app-portage/gpyutils/files/implementations.txt11
-rw-r--r--app-portage/gpyutils/gpyutils-0.13.1.ebuild31
-rw-r--r--app-portage/gpyutils/gpyutils-0.6.1.ebuild26
-rw-r--r--app-portage/gpyutils/gpyutils-9999.ebuild25
-rw-r--r--app-portage/gpyutils/metadata.xml5
6 files changed, 42 insertions, 58 deletions
diff --git a/app-portage/gpyutils/Manifest b/app-portage/gpyutils/Manifest
index c22e9d08ffbe..31f8a41bf10f 100644
--- a/app-portage/gpyutils/Manifest
+++ b/app-portage/gpyutils/Manifest
@@ -1 +1 @@
-DIST gpyutils-0.6.1.tar.gz 23914 BLAKE2B 1e799ce33a949037b68262cb7a6ca5fd99b4ca4ec74c3044bfb31ea08b59906a21f6c96cdf99330f6af16d68be6ee7ab49c3cf05979691899abaacc9d62032eb SHA512 74d984e496ccfa7124cfefd9f8f79d5fab4bb4dbf5e61f4400b39367dd54e23b871f286eef28007a5c255b862533a34948449bbf7aed55cf8fe315e76ac876ea
+DIST gpyutils-0.13.1.gh.tar.gz 31758 BLAKE2B a7eb282dff3b65e7cdf50c3ae5d787a4cdc49bda2030d88525b5d1752eafb5b9548873832512f3b9449eeef26198adea89b8e339e997a002eea32215c8a5b783 SHA512 0126f6f1253d39dca6ff2c2191c44831c562494883b8d6e48b6b313914689f5389acc2fde2eba21d538a452d3eea3ee92057ca1ba2edb72bd293b6731f4959ef
diff --git a/app-portage/gpyutils/files/implementations.txt b/app-portage/gpyutils/files/implementations.txt
index f8f378e84459..45705e04e3e1 100644
--- a/app-portage/gpyutils/files/implementations.txt
+++ b/app-portage/gpyutils/files/implementations.txt
@@ -17,16 +17,19 @@ python3_4 dead 3.4
python3_5 dead 3.5
python3_6 dead 3.6
python3_7 dead 3.7
-python3_8 old 3.8
-python3_9 current 3.9
-python3_10 supported 3.10
+python3_8 dead 3.8
+python3_9 dead 3.9
+python3_10 old 3.10
+python3_11 old 3.11
+python3_12 current 3.12
+python3_13 experimental 3.13
pypy1_8 2.7-pypy-1.8 dead p1.8
pypy1_9 2.7-pypy-1.9 dead p1.9
pypy2_0 2.7-pypy-2.0 dead p2.0
pypy dead pypy
-pypy3 supported pypy3
+pypy3 experimental pypy3
jython2_5 2.5-jython dead j2.5
jython2_7 2.7-jython dead j2.7
diff --git a/app-portage/gpyutils/gpyutils-0.13.1.ebuild b/app-portage/gpyutils/gpyutils-0.13.1.ebuild
new file mode 100644
index 000000000000..3e8b40b49ef2
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.13.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="
+ https://github.com/projg2/gpyutils/
+ https://pypi.org/project/gpyutils/
+"
+SRC_URI="
+ https://github.com/projg2/gpyutils/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc x86"
+
+RDEPEND="
+ >=app-portage/gentoopm-0.3.2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/app-portage/gpyutils/gpyutils-0.6.1.ebuild b/app-portage/gpyutils/gpyutils-0.6.1.ebuild
deleted file mode 100644
index caf527892cce..000000000000
--- a/app-portage/gpyutils/gpyutils-0.6.1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Utitilies for maintaining Python packages"
-HOMEPAGE="https://github.com/mgorny/gpyutils/"
-SRC_URI="
- https://github.com/mgorny/gpyutils/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND=">=app-portage/gentoopm-0.3.2[${PYTHON_USEDEP}]"
-
-python_test() {
- esetup.py test
-}
diff --git a/app-portage/gpyutils/gpyutils-9999.ebuild b/app-portage/gpyutils/gpyutils-9999.ebuild
deleted file mode 100644
index c1d6bf513297..000000000000
--- a/app-portage/gpyutils/gpyutils-9999.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{8..10} )
-
-EGIT_REPO_URI="https://github.com/mgorny/gpyutils.git"
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Utitilies for maintaining Python packages"
-HOMEPAGE="https://github.com/mgorny/gpyutils/"
-SRC_URI=""
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-RDEPEND=">=app-portage/gentoopm-0.3.2[${PYTHON_USEDEP}]"
-
-python_test() {
- esetup.py test
-}
diff --git a/app-portage/gpyutils/metadata.xml b/app-portage/gpyutils/metadata.xml
index f25e0a24ce6c..89201d449b7c 100644
--- a/app-portage/gpyutils/metadata.xml
+++ b/app-portage/gpyutils/metadata.xml
@@ -11,7 +11,8 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
- <bugs-to>https://github.com/mgorny/gpyutils/issues/</bugs-to>
- <remote-id type="github">mgorny/gpyutils</remote-id>
+ <bugs-to>https://github.com/projg2/gpyutils/issues/</bugs-to>
+ <remote-id type="github">projg2/gpyutils</remote-id>
+ <remote-id type="pypi">gpyutils</remote-id>
</upstream>
</pkgmetadata>