summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/grs/grs-9999.ebuild')
-rw-r--r--app-portage/grs/grs-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/app-portage/grs/grs-9999.ebuild b/app-portage/grs/grs-9999.ebuild
index 4ed7aad6371f..540cf24b2eb6 100644
--- a/app-portage/grs/grs-9999.ebuild
+++ b/app-portage/grs/grs-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-PYTHON_COMPAT=( python3_{8,9} )
+EAPI="8"
+PYTHON_COMPAT=( python3_{9,10,11} )
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1 linux-info
@@ -28,7 +28,7 @@ IUSE="server"
DEPEND=""
RDEPEND="
- sys-apps/portage
+ sys-apps/portage[${PYTHON_USEDEP}]
server? (
app-arch/tar[xattr]
app-cdr/cdrtools
@@ -37,10 +37,7 @@ RDEPEND="
dev-vcs/git
net-misc/rsync
sys-fs/squashfs-tools
- || (
- sys-kernel/genkernel
- sys-kernel/genkernel-next
- )
+ sys-kernel/genkernel
)"
pkg_setup() {
@@ -58,5 +55,7 @@ src_install() {
if use server; then
mkdir "${D}"/usr/share/${PN}
cp "${DISTDIR}"/${ISO} "${D}"/usr/share/${PN}
+ else
+ rm "${D}"/usr/bin/grsrun
fi
}