summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gs-pypi/gs-pypi-0.2.1.ebuild')
-rw-r--r--app-portage/gs-pypi/gs-pypi-0.2.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-portage/gs-pypi/gs-pypi-0.2.1.ebuild b/app-portage/gs-pypi/gs-pypi-0.2.1.ebuild
new file mode 100644
index 000000000000..fa593fbf828b
--- /dev/null
+++ b/app-portage/gs-pypi/gs-pypi-0.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="g-sorcery backend for pypi packages"
+HOMEPAGE="https://github.com/jauhien/gs-pypi"
+SRC_URI="https://github.com/jauhien/gs-pypi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=app-portage/g-sorcery-0.2.1[bson(-),git(-),$(python_gen_usedep 'python*')]
+ dev-python/beautifulsoup:4[$(python_gen_usedep 'python*')]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman docs/*.8
+}