summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/hackport')
-rw-r--r--app-portage/hackport/Manifest4
-rw-r--r--app-portage/hackport/files/hackport.bash.completion14
-rw-r--r--app-portage/hackport/hackport-0.6.6.ebuild54
-rw-r--r--app-portage/hackport/hackport-0.7.2.2.ebuild69
-rw-r--r--app-portage/hackport/hackport-0.7.ebuild58
-rw-r--r--app-portage/hackport/hackport-0.8.4.0.ebuild87
-rw-r--r--app-portage/hackport/hackport-9999.ebuild109
-rw-r--r--app-portage/hackport/metadata.xml8
8 files changed, 248 insertions, 155 deletions
diff --git a/app-portage/hackport/Manifest b/app-portage/hackport/Manifest
index 8c6f72c36bae..64c31175a24d 100644
--- a/app-portage/hackport/Manifest
+++ b/app-portage/hackport/Manifest
@@ -1,2 +1,2 @@
-DIST hackport-0.6.6.tar.gz 2079279 BLAKE2B 6e4084babb3fc036568387845ca2793d47a29ce94c24211259324d3040d0c0e15be028d0a9726ea8512dd518d7e9dd8447aba67725c0916418f523449f2179b4 SHA512 b836bd21e3713796feaab9ca830fdef80f52b9723d0fba6cfb60d802e038eaec2da8492eb025d6ae376aea69734c031e23c0887642675c4f767b1592d82c5523
-DIST hackport-0.7.tar.gz 2080625 BLAKE2B 87c70180df45c2bd6c6e51dff31b31c45d0c3c572223803daed8f2b9045ececa63edea1b9f35984067b393b25a31e78c761a12478c1dce6e9cc57dc4c0f1b4b0 SHA512 72f1638d2007d8b085c8dcb8d01b171c6a0e8306c71efc7be7ffc8d3e2a6fdee8e74c2bb62e8762a4315e3384d2f78ac12d45faf79b94270c638a9afc7cc1a82
+DIST hackport-0.7.2.2.tar.gz 2083323 BLAKE2B e14fbd5c5fa88260518869ad72dd59d08e7cb4351cecc35952ebfdd71e34ea335e6c4b56de7577033335e3efdbff8796fd05f1ad3df20ae84ed1bc8ef7b2153f SHA512 ce880ae8a5a4dc1d446654b8bf4108bacf4a974afaad0266c291ff9f2ab6f8af49294452314cbbeec1979c8e5ffab0860d87668f63d7d7731eb11eb3144a4bd0
+DIST hackport-0.8.4.0.tar.gz 2427117 BLAKE2B fac57e56cb09d32bd51abd5cb209920176682578cb198675d8dfca82b5b6851a5ea26758b9d83f3db74b5bc03a3ed9cb33372b56e9c314e3fdbb5fc24953e722 SHA512 4ecdc4e0eef0f27b4a79c4ad20676296d925fd51f113f701718f230ca9af2068bb44ef355cc0fdb22dceec11c2fe7aee14887bf2994d49f43bd5cfc66c9b7a79
diff --git a/app-portage/hackport/files/hackport.bash.completion b/app-portage/hackport/files/hackport.bash.completion
new file mode 100644
index 000000000000..687c2046c4c2
--- /dev/null
+++ b/app-portage/hackport/files/hackport.bash.completion
@@ -0,0 +1,14 @@
+_hackport()
+{
+ local CMDLINE
+ local IFS=$'\n'
+ CMDLINE=(+RTS -I0 -A8M -N1 -qg -RTS --bash-completion-index $COMP_CWORD)
+
+ for arg in ${COMP_WORDS[@]}; do
+ CMDLINE=(${CMDLINE[@]} --bash-completion-word $arg)
+ done
+
+ COMPREPLY=( $(/usr/bin/hackport "${CMDLINE[@]}") )
+}
+
+complete -o filenames -F _hackport hackport
diff --git a/app-portage/hackport/hackport-0.6.6.ebuild b/app-portage/hackport/hackport-0.6.6.ebuild
deleted file mode 100644
index 149aa49011ec..000000000000
--- a/app-portage/hackport/hackport-0.6.6.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.5.9999
-
-CABAL_FEATURES="test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Hackage and Portage integration tool"
-HOMEPAGE="https://hackage.haskell.org/package/hackport"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="app-portage/repoman
- >=dev-haskell/async-2.0:=
- >=dev-haskell/base16-bytestring-0.1.1:=
- >=dev-haskell/base64-bytestring-1.0:=
- >=dev-haskell/cryptohash-sha256-0.11:=
- dev-haskell/ed25519:=
- dev-haskell/extensible-exceptions:=
- >=dev-haskell/hashable-1.0:=
- >=dev-haskell/http-4000.1.5:=
- >=dev-haskell/lukko-0.1:=
- >=dev-haskell/mtl-2.1:=
- >=dev-haskell/network-2.6:=
- >=dev-haskell/network-uri-2.6:=
- >=dev-haskell/old-locale-1.0:=
- >=dev-haskell/parsec-3.1.13:=
- >=dev-haskell/random-1.0:=
- dev-haskell/split:=
- >=dev-haskell/stm-2.0:=
- >=dev-haskell/tar-0.5:=
- >=dev-haskell/text-1.2.3.0:=
- >=dev-haskell/xml-1.3.7:=
- >=dev-haskell/zlib-0.5.3:=
- >=dev-lang/ghc-8.0.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.24.0.0
- test? ( >=dev-haskell/doctest-0.8
- >=dev-haskell/hspec-2.0
- >=dev-haskell/quickcheck-2.0 )
-"
-
-src_install() {
- haskell-cabal_src_install
- doman man/hackport.1
-}
diff --git a/app-portage/hackport/hackport-0.7.2.2.ebuild b/app-portage/hackport/hackport-0.7.2.2.ebuild
new file mode 100644
index 000000000000..9caa117dedee
--- /dev/null
+++ b/app-portage/hackport/hackport-0.7.2.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: +cabal-v1
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Hackage and Portage integration tool"
+HOMEPAGE="https://hackage.haskell.org/package/hackport"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+GHC_BOOTSTRAP_PACKAGES=(
+ cabal-doctest
+)
+
+RDEPEND=">=dev-haskell/async-2.0:=
+ >=dev-haskell/base16-bytestring-0.1.1:=
+ >=dev-haskell/base64-bytestring-1.0:=
+ >=dev-haskell/cryptohash-sha256-0.11:=
+ >=dev-haskell/echo-0.1.3:=
+ >=dev-haskell/ed25519-0.0:=
+ >=dev-haskell/edit-distance-0.2.2:=
+ dev-haskell/extensible-exceptions:=
+ >=dev-haskell/hashable-1.0:=
+ >=dev-haskell/http-4000.1.5:=
+ >=dev-haskell/network-3.0:=
+ >=dev-haskell/network-uri-2.6.0.2:=
+ >=dev-haskell/parallel-3.2.1.0:=
+ dev-haskell/quickcheck:=
+ >=dev-haskell/random-1:=
+ >=dev-haskell/regex-base-0.94.0.0:=
+ >=dev-haskell/regex-posix-0.96.0.0:=
+ >=dev-haskell/resolv-0.1.1:=
+ dev-haskell/split:=
+ >=dev-haskell/stm-2.0:=
+ >=dev-haskell/tar-0.5.0.3:=
+ dev-haskell/xml:=
+ >=dev-haskell/zlib-0.5.3:=
+ >=dev-lang/ghc-8.4.3:= <dev-lang/ghc-9.1
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/base-compat
+ dev-haskell/cabal-doctest
+ >=dev-haskell/doctest-0.8
+ dev-haskell/glob
+ >=dev-haskell/hspec-2.0
+ >=dev-haskell/quickcheck-2.0 )
+"
+RDEPEND+="
+ dev-util/pkgcheck
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=cabal-v1
+}
+
+src_install() {
+ haskell-cabal_src_install
+ doman man/hackport.1
+}
diff --git a/app-portage/hackport/hackport-0.7.ebuild b/app-portage/hackport/hackport-0.7.ebuild
deleted file mode 100644
index bbe4e16168c8..000000000000
--- a/app-portage/hackport/hackport-0.7.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.6.9999
-
-CABAL_FEATURES="test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Hackage and Portage integration tool"
-HOMEPAGE="https://hackage.haskell.org/package/hackport"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/async-2.0:=
- >=dev-haskell/base16-bytestring-0.1.1:= <dev-haskell/base16-bytestring-1:=
- >=dev-haskell/base64-bytestring-1.0:=
- >=dev-haskell/cryptohash-sha256-0.11:=
- dev-haskell/ed25519:=
- dev-haskell/extensible-exceptions:=
- >=dev-haskell/hashable-1.0:=
- >=dev-haskell/http-4000.1.5:=
- >=dev-haskell/lukko-0.1:=
- >=dev-haskell/mtl-2.1:=
- >=dev-haskell/network-2.6:=
- >=dev-haskell/network-uri-2.6:=
- >=dev-haskell/old-locale-1.0:=
- >=dev-haskell/parallel-3.2.1.0:=
- >=dev-haskell/parsec-3.1.13:=
- >=dev-haskell/random-1.0:=
- dev-haskell/split:=
- >=dev-haskell/stm-2.0:=
- >=dev-haskell/tar-0.5:=
- >=dev-haskell/text-1.2.3.0:=
- >=dev-haskell/xml-1.3.7:=
- >=dev-haskell/zlib-0.5.3:=
- >=dev-lang/ghc-8.0.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.24.0.0
- test? ( >=dev-haskell/doctest-0.8
- >=dev-haskell/hspec-2.0
- >=dev-haskell/quickcheck-2.0 )
-"
-RDEPEND+="
- app-portage/repoman
- dev-util/pkgcheck
-"
-
-src_install() {
- haskell-cabal_src_install
- doman man/hackport.1
-}
diff --git a/app-portage/hackport/hackport-0.8.4.0.ebuild b/app-portage/hackport/hackport-0.8.4.0.ebuild
new file mode 100644
index 000000000000..624f4ffddd58
--- /dev/null
+++ b/app-portage/hackport/hackport-0.8.4.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +cabal-v1,+gentoo-tests,+pedantic
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal bash-completion-r1
+DESCRIPTION="Hackage and Portage integration tool"
+HOMEPAGE="https://github.com/gentoo-haskell/hackport#readme"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="profile"
+
+RDEPEND="
+ >=dev-haskell/async-2.0:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1.1:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?]
+ >=dev-haskell/cryptohash-sha256-0.11:=[profile?]
+ dev-haskell/dlist:=[profile?]
+ >=dev-haskell/echo-0.1.3:=[profile?]
+ >=dev-haskell/ed25519-0.0:=[profile?]
+ >=dev-haskell/edit-distance-0.2.2:=[profile?]
+ dev-haskell/extensible-exceptions:=[profile?]
+ >=dev-haskell/hashable-1.0:=[profile?]
+ >=dev-haskell/http-4000.1.5:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/lukko-0.1:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/network-3.0:=[profile?]
+ >=dev-haskell/network-uri-2.6.0.2:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ >=dev-haskell/parallel-3.2.1.0:=[profile?]
+ >=dev-haskell/parsec-3.1.13.0:=[profile?]
+ dev-haskell/parser-combinators:=[profile?]
+ dev-haskell/prettyprinter:=[profile?]
+ dev-haskell/quickcheck:=
+ >=dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/regex-base-0.94.0.0:=[profile?]
+ >=dev-haskell/regex-posix-0.96.0.0:=[profile?]
+ >=dev-haskell/resolv-0.1.1:=[profile?]
+ >=dev-haskell/safe-exceptions-0.1.7.0:=[profile?]
+ dev-haskell/split:=[profile?]
+ >=dev-haskell/tar-0.5.0.3:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-haskell/zlib-0.5.3:=[profile?]
+ >=dev-lang/ghc-8.10.6:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ dev-haskell/base-compat
+ >=dev-haskell/cabal-doctest-1.0
+ >=dev-haskell/doctest-0.8
+ dev-haskell/glob
+ >=dev-haskell/hspec-2.0
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.0
+ )
+"
+
+src_configure() {
+ if use test; then
+ export GHC_BOOTSTRAP_PACKAGES=(
+ cabal-doctest
+ )
+ fi
+
+ haskell-cabal_src_configure \
+ --flag=cabal-v1 \
+ --flag=gentoo-tests \
+ --flag=pedantic \
+ $(cabal_flag profile profile)
+}
+
+src_install() {
+ haskell-cabal_src_install
+ doman man/hackport.1
+
+ # We only install bash completion scripts currently
+ newbashcomp "${FILESDIR}/${PN}.bash.completion" "${PN}"
+}
diff --git a/app-portage/hackport/hackport-9999.ebuild b/app-portage/hackport/hackport-9999.ebuild
index 6853550d5f1f..6845afdc9bf7 100644
--- a/app-portage/hackport/hackport-9999.ebuild
+++ b/app-portage/hackport/hackport-9999.ebuild
@@ -1,62 +1,97 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-# ebuild generated by hackport 0.5.1.9999
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +cabal-v1,+gentoo-tests,+pedantic
CABAL_FEATURES="test-suite"
EGIT_REPO_URI="https://github.com/gentoo-haskell/hackport.git"
-inherit git-r3 haskell-cabal
+inherit git-r3 haskell-cabal bash-completion-r1
DESCRIPTION="Hackage and Portage integration tool"
-HOMEPAGE="https://github.com/gentoo-haskell/hackport"
+HOMEPAGE="https://github.com/gentoo-haskell/hackport#readme"
-LICENSE="GPL-2"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
-IUSE=""
-
-RESTRICT=test # tests are broken: need path to ebuild tree
+IUSE="profile +threads"
+REQUIRED_USE="profile? ( threads ) test? ( threads )"
RDEPEND="
- app-portage/repoman
- dev-haskell/async:=
- dev-haskell/base16-bytestring:=
- dev-haskell/base64-bytestring:=
- dev-haskell/cryptohash:=
- dev-haskell/ed25519:=
- dev-haskell/extensible-exceptions:=
- dev-haskell/hashable:=
- >=dev-haskell/http-4000.0.3:=
- dev-haskell/missingh:=
- dev-haskell/mtl:=
- >=dev-haskell/network-2.6:=
- >=dev-haskell/network-uri-2.6:=
- dev-haskell/old-locale:=
- dev-haskell/old-time:=
- dev-haskell/parsec:=
- dev-haskell/random:=
- dev-haskell/regex-compat:=
- dev-haskell/split:=
- dev-haskell/stm:=
- >=dev-haskell/tar-0.5:=
- >=dev-haskell/xml-1.3.7:=
- dev-haskell/zlib:=
- >=dev-lang/ghc-7.8.2:=
+ >=dev-haskell/async-2.0:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1.1:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?]
+ >=dev-haskell/cryptohash-sha256-0.11:=[profile?]
+ dev-haskell/dlist:=[profile?]
+ >=dev-haskell/echo-0.1.3:=[profile?]
+ >=dev-haskell/ed25519-0.0:=[profile?]
+ >=dev-haskell/edit-distance-0.2.2:=[profile?]
+ dev-haskell/extensible-exceptions:=[profile?]
+ >=dev-haskell/hashable-1.0:=[profile?]
+ >=dev-haskell/http-4000.1.5:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/lukko-0.1:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/network-3.0:=[profile?]
+ >=dev-haskell/network-uri-2.6.0.2:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ >=dev-haskell/parallel-3.2.1.0:=[profile?]
+ >=dev-haskell/parsec-3.1.13.0:=[profile?]
+ dev-haskell/parser-combinators:=[profile?]
+ dev-haskell/prettyprinter:=[profile?]
+ dev-haskell/quickcheck:=
+ >=dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/regex-base-0.94.0.0:=[profile?]
+ >=dev-haskell/regex-posix-0.96.0.0:=[profile?]
+ >=dev-haskell/resolv-0.1.1:=[profile?]
+ >=dev-haskell/safe-exceptions-0.1.7.0:=[profile?]
+ dev-haskell/split:=[profile?]
+ >=dev-haskell/tar-0.5.0.3:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-haskell/zlib-0.5.3:=[profile?]
+ >=dev-lang/ghc-8.10.6:=[profile?]
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
- test? ( dev-haskell/hunit )
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ dev-haskell/base-compat
+ >=dev-haskell/cabal-doctest-1.0
+ >=dev-haskell/doctest-0.8
+ dev-haskell/glob
+ >=dev-haskell/hspec-2.0
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.0
+ )
"
src_prepare() {
- default
- sed -e 's/^Version:.*/&.9999/' -i ${PN}.cabal || die # just to distinct from release install
+ haskell-cabal_src_prepare
+ sed -e 's/^version:.*/&.9999/' -i ${PN}.cabal || die # just to distinguish from release install
+}
+
+src_configure() {
+ if use test; then
+ export GHC_BOOTSTRAP_PACKAGES=(
+ cabal-doctest
+ )
+ fi
+
+ haskell-cabal_src_configure \
+ --flag=cabal-v1 \
+ --flag=gentoo-tests \
+ --flag=pedantic \
+ $(cabal_flag profile profile) \
+ $(cabal-flag threads threads)
}
src_install() {
haskell-cabal_src_install
doman man/hackport.1
+
+ # We only install bash completion scripts currently
+ newbashcomp "${FILESDIR}/${PN}.bash.completion" "${PN}"
}
diff --git a/app-portage/hackport/metadata.xml b/app-portage/hackport/metadata.xml
index bedf907374d9..168e097f4c4c 100644
--- a/app-portage/hackport/metadata.xml
+++ b/app-portage/hackport/metadata.xml
@@ -5,11 +5,11 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- A command line tool to manage an overlay of Gentoo ebuilds
- that are generated from a hackage repo of Cabal packages.
- </longdescription>
+ <use>
+ <flag name="profile">Enable profiling flags</flag>
+ </use>
<upstream>
+ <remote-id type="hackage">hackport</remote-id>
<remote-id type="github">gentoo-haskell/hackport</remote-id>
</upstream>
</pkgmetadata>