summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/metagen')
-rw-r--r--app-portage/metagen/Manifest3
-rw-r--r--app-portage/metagen/metadata.xml3
-rw-r--r--app-portage/metagen/metagen-0.7.2.ebuild30
-rw-r--r--app-portage/metagen/metagen-0.7.3-r2.ebuild (renamed from app-portage/metagen/metagen-0.7.2-r1.ebuild)18
-rw-r--r--app-portage/metagen/metagen-0.7.3-r3.ebuild (renamed from app-portage/metagen/metagen-0.7.2-r2.ebuild)20
-rw-r--r--app-portage/metagen/metagen-0.7.4.ebuild32
-rw-r--r--app-portage/metagen/metagen-9999.ebuild16
7 files changed, 66 insertions, 56 deletions
diff --git a/app-portage/metagen/Manifest b/app-portage/metagen/Manifest
index c08b2074a5a2..215aa06d8cfa 100644
--- a/app-portage/metagen/Manifest
+++ b/app-portage/metagen/Manifest
@@ -1 +1,2 @@
-DIST metagen-0.7.2.tar.gz 8391 BLAKE2B 3ec53ff7fa12ea816c88bcbd4e45a3cc66527e6a507f01bc8934abc6bb6ae142e6c6620f82af7c6775b9001d6549832d6fab42c1b44c966f72a40ec0a0f66b2a SHA512 8a78d47ce8228df73a36d4c0f346d75250fbf8568ca6c8cc9ff9313b61c43ba514cf6dc13b36ea90f1ea5b194337748224ff81449d56527fbfc6b7a91e408054
+DIST metagen-0.7.3.tar.gz 9607 BLAKE2B 3c5b9debf10b0a6dda9bdf0e45e157c80019d0496d93f5af18e7be1b502c320fdbf7bd28f382e9021580d3aaa373566d7b342f3fa57f736fcb3676bafdd4d6e2 SHA512 d7293125685ad3be35dd9213b5d52c9219b6a5bcee4ab15fb2426bdccdb95b4df5567c2178bdefc0e75987080cd51026b5b089a4d4cf6402f455429d55d3a9e8
+DIST metagen-0.7.4.tar.gz 9291 BLAKE2B a1ad7267202f8bc477002a4c9deeb0cd26c8f2163f4fb3a0bf74e39b46448f3ba29dcec1201f41a0e98af8780b219102f3733b957a4e87293cc5e04486e39755 SHA512 e3d37cbe32fabbc980185d9948f6a38dfca756f727d86c26f7f5bd92e768bc034bffa14995844347bb3e19fe2d8757dcb45a3cab5b9e58d97c9c562b75a90d26
diff --git a/app-portage/metagen/metadata.xml b/app-portage/metagen/metadata.xml
index 6a22e9e318bb..32307ccfc35f 100644
--- a/app-portage/metagen/metadata.xml
+++ b/app-portage/metagen/metadata.xml
@@ -5,4 +5,7 @@
<email>sping@gentoo.org</email>
<name>Sebastian Pipping</name>
</maintainer>
+ <upstream>
+ <remote-id type="pypi">metagen</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-portage/metagen/metagen-0.7.2.ebuild b/app-portage/metagen/metagen-0.7.2.ebuild
deleted file mode 100644
index a970ed88aeaa..000000000000
--- a/app-portage/metagen/metagen-0.7.2.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="metadata.xml generator for ebuilds"
-HOMEPAGE="https://cgit.gentoo.org/proj/metagen.git"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~hppa ppc x86 ~amd64-linux ~x86-linux"
-
-IUSE=""
-DEPEND="dev-python/lxml[${PYTHON_USEDEP}]
- sys-apps/portage[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-python_install_all() {
- distutils-r1_python_install_all
- doman docs/metagen.1
-}
-
-python_test() {
- "${PYTHON}" -c "from metagen import metagenerator; metagenerator.do_tests()" || die
-}
diff --git a/app-portage/metagen/metagen-0.7.2-r1.ebuild b/app-portage/metagen/metagen-0.7.3-r2.ebuild
index d1dd1c123139..930c202fcc26 100644
--- a/app-portage/metagen/metagen-0.7.2-r1.ebuild
+++ b/app-portage/metagen/metagen-0.7.3-r2.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-PYTHON_COMPAT=( python3_{7..10} )
+EAPI="8"
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="metadata.xml generator for ebuilds"
HOMEPAGE="https://cgit.gentoo.org/proj/metagen.git"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm64 ~hppa ppc ~riscv x86 ~amd64-linux ~x86-linux"
IUSE=""
DEPEND="dev-python/lxml[${PYTHON_USEDEP}]
@@ -22,6 +22,12 @@ RDEPEND="${DEPEND}"
python_install_all() {
distutils-r1_python_install_all
doman docs/metagen.1
+
+ # Bug 814545 and 832069
+ if [[ ${PF} != ${P} ]]; then # to be robust across bumps
+ mv "${ED}"/usr/share/doc/${P}/* "${ED}"/usr/share/doc/${PF}/ || die
+ rmdir "${ED}"/usr/share/doc/${P}/ || die
+ fi
}
python_test() {
diff --git a/app-portage/metagen/metagen-0.7.2-r2.ebuild b/app-portage/metagen/metagen-0.7.3-r3.ebuild
index c0b8ff11a9d2..d4b7f124125a 100644
--- a/app-portage/metagen/metagen-0.7.2-r2.ebuild
+++ b/app-portage/metagen/metagen-0.7.3-r3.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-PYTHON_COMPAT=( python3_{7..10} )
+EAPI="8"
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="metadata.xml generator for ebuilds"
HOMEPAGE="https://cgit.gentoo.org/proj/metagen.git"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
IUSE=""
DEPEND="dev-python/lxml[${PYTHON_USEDEP}]
@@ -23,9 +23,11 @@ python_install_all() {
distutils-r1_python_install_all
doman docs/metagen.1
- # Bug 814545
- mv "${D}"/usr/share/doc/${P}/* "${D}"/usr/share/doc/${PF}/ || die
- rmdir "${D}"/usr/share/doc/${P}/ || die
+ # Bug 814545 and 832069
+ if [[ ${PF} != ${P} ]]; then # to be robust across bumps
+ mv "${ED}"/usr/share/doc/${P}/* "${ED}"/usr/share/doc/${PF}/ || die
+ rmdir "${ED}"/usr/share/doc/${P}/ || die
+ fi
}
python_test() {
diff --git a/app-portage/metagen/metagen-0.7.4.ebuild b/app-portage/metagen/metagen-0.7.4.ebuild
new file mode 100644
index 000000000000..3a735ec891c4
--- /dev/null
+++ b/app-portage/metagen/metagen-0.7.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="metadata.xml generator for ebuilds"
+HOMEPAGE="https://cgit.gentoo.org/proj/metagen.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~hppa ppc ~riscv x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-python/lxml[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman docs/metagen.1
+
+ # Bug 814545 and 832069
+ if [[ ${PF} != ${P} ]]; then # to be robust across bumps
+ mv "${ED}"/usr/share/doc/${P}/* "${ED}"/usr/share/doc/${PF}/ || die
+ rmdir "${ED}"/usr/share/doc/${P}/ || die
+ fi
+}
diff --git a/app-portage/metagen/metagen-9999.ebuild b/app-portage/metagen/metagen-9999.ebuild
index d0a3f9c8dbba..af57fda6c7ea 100644
--- a/app-portage/metagen/metagen-9999.ebuild
+++ b/app-portage/metagen/metagen-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+EAPI="8"
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
inherit distutils-r1 git-r3
@@ -23,14 +23,10 @@ RDEPEND="${DEPEND}"
python_install_all() {
distutils-r1_python_install_all
doman docs/metagen.1
-}
-
-src_install() {
- distutils-r1_src_install
# Address expected path warning for /usr/share/doc/metagen-<not-9999>
- mv "${D}"/usr/share/doc/metagen-{*.*.*/*,${PV}/} || die
- rmdir "${D}"/usr/share/doc/metagen-*.*.*/ || die
+ mv "${ED}"/usr/share/doc/metagen-{*.*.*/*,${PV}/} || die
+ rmdir "${ED}"/usr/share/doc/metagen-*.*.*/ || die
}
python_test() {