summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/portage-utils/portage-utils-9999.ebuild')
-rw-r--r--app-portage/portage-utils/portage-utils-9999.ebuild87
1 files changed, 42 insertions, 45 deletions
diff --git a/app-portage/portage-utils/portage-utils-9999.ebuild b/app-portage/portage-utils/portage-utils-9999.ebuild
index 423703f19f3f..64f18b80703d 100644
--- a/app-portage/portage-utils/portage-utils-9999.ebuild
+++ b/app-portage/portage-utils/portage-utils-9999.ebuild
@@ -1,73 +1,70 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Small and fast Portage helper tools written in C"
HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="nls static openmp +qmanifest +qtegrity libressl"
-
if [[ ${PV} == *9999 ]]; then
inherit git-r3 autotools
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage-utils.git"
else
SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
fi
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="openmp +qmanifest static"
+
RDEPEND="
- static? ( dev-libs/iniparser:0[static-libs] )
- !static? ( dev-libs/iniparser:0 )
+ openmp? ( || (
+ sys-devel/gcc:*[openmp]
+ sys-libs/libomp
+ ) )
qmanifest? (
- openmp? (
- || (
- >=sys-devel/gcc-4.2:*[openmp]
- sys-devel/clang-runtime:*[openmp]
- )
- )
- static? (
- app-crypt/libb2:=[static-libs]
- !libressl? ( dev-libs/openssl:0=[static-libs] )
- libressl? ( dev-libs/libressl:0=[static-libs] )
- sys-libs/zlib:=[static-libs]
- app-crypt/gpgme:=[static-libs]
- )
!static? (
+ app-crypt/gpgme:=
app-crypt/libb2:=
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
sys-libs/zlib:=
- app-crypt/gpgme:=
- )
- )
- qtegrity? (
- openmp? (
- || (
- >=sys-devel/gcc-4.2:*[openmp]
- sys-devel/clang-runtime:*[openmp]
- )
)
+ )"
+DEPEND="${RDEPEND}
+ qmanifest? (
static? (
- !libressl? ( dev-libs/openssl:0=[static-libs] )
- libressl? ( dev-libs/libressl:0=[static-libs] )
+ app-crypt/gpgme[static-libs]
+ app-crypt/libb2[static-libs]
+ sys-libs/zlib[static-libs]
)
- !static? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- )
-"
-DEPEND="${RDEPEND}"
+ )"
+BDEPEND="virtual/pkgconfig"
+
+# bug #898362, gnulib explicit checks
+QA_CONFIG_IMPL_DECL_SKIP=(
+ "MIN"
+ "unreachable"
+ "alignof"
+ "static_assert"
+)
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
src_configure() {
+ use static && append-ldflags -static
+
econf \
--disable-maintainer-mode \
--with-eprefix="${EPREFIX}" \
$(use_enable qmanifest) \
- $(use_enable qtegrity) \
- $(use_enable openmp) \
- $(use_enable static)
+ $(use_enable openmp)
}