summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/recover-broken-vdb')
-rw-r--r--app-portage/recover-broken-vdb/Manifest3
-rw-r--r--app-portage/recover-broken-vdb/recover-broken-vdb-0.0.9.ebuild29
-rw-r--r--app-portage/recover-broken-vdb/recover-broken-vdb-1.0.0-r2.ebuild (renamed from app-portage/recover-broken-vdb/recover-broken-vdb-0.0.7.ebuild)12
-rw-r--r--app-portage/recover-broken-vdb/recover-broken-vdb-9999.ebuild12
4 files changed, 15 insertions, 41 deletions
diff --git a/app-portage/recover-broken-vdb/Manifest b/app-portage/recover-broken-vdb/Manifest
index 96670970a580..fc0fa9f1efd2 100644
--- a/app-portage/recover-broken-vdb/Manifest
+++ b/app-portage/recover-broken-vdb/Manifest
@@ -1,2 +1 @@
-DIST recover-broken-vdb-0.0.7.tar.gz 13336 BLAKE2B 0c7d2dc73ca6e525edf190caee56f76e918559a4c0da322bb93b5807554d214fd01b53b0cc5c983fa9009b98a5d71f5aac542b26fe6656b9f81989e159f20d8c SHA512 447effe9664781095e8fd9760ff7f63f8b10466299c002e20da3d226843fa9c24a50b2c8f9eebaaa07cecd75a17272757c0e2175dd81e8daf2a59fa7233bc4a3
-DIST recover-broken-vdb-0.0.9.tar.gz 15410 BLAKE2B c8fffa07e817ef2ff825add92aac732036676dd08b2cbdcca60a7c1fa2fc740f0473be2147635701971fb9a0a871c65115a1fa9ea05486cffe747207e432d8fd SHA512 0fd9f5e0d046344ac6c86e446b7c52c11238b1d90cf330558da357b71b5fa577b157adfc6903e94f065de6afb0296df2ae191078836311792ec319f614e39d37
+DIST recover-broken-vdb-1.0.0.tar.gz 15723 BLAKE2B a2c39f64f1db3c0cb1e285deb37654575f35fbdd419b5eaabef52293299e70d98cf7804654f596655fb68beff88699cb9f87628ea29ffd1a29cf2893589f9508 SHA512 4a6428b65c33be4128936423c6770f6af9574fe6caef90837a7d9a1d62d4a595c798b29021f81df4dcd39db4e086abb18f256345f2a8f1e0e7c6687863dea092
diff --git a/app-portage/recover-broken-vdb/recover-broken-vdb-0.0.9.ebuild b/app-portage/recover-broken-vdb/recover-broken-vdb-0.0.9.ebuild
deleted file mode 100644
index ce233e99dd61..000000000000
--- a/app-portage/recover-broken-vdb/recover-broken-vdb-0.0.9.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Check Portage's VDB for internal inconsistency on ELF metadata"
-HOMEPAGE="https://github.com/thesamesam/recover-broken-vdb"
-if [[ ${PV} == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/thesamesam/recover-broken-vdb.git"
-else
- SRC_URI="https://github.com/thesamesam/recover-broken-vdb/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-# Require latest version of pax-utils to avoid users breaking their systems again
-# The tool itself works fine with older versions
-RDEPEND=">=app-misc/pax-utils-1.3.3
- sys-apps/file
- $(python_gen_cond_dep 'sys-apps/portage[${PYTHON_USEDEP}]')"
diff --git a/app-portage/recover-broken-vdb/recover-broken-vdb-0.0.7.ebuild b/app-portage/recover-broken-vdb/recover-broken-vdb-1.0.0-r2.ebuild
index ce233e99dd61..81aa80b87351 100644
--- a/app-portage/recover-broken-vdb/recover-broken-vdb-0.0.7.ebuild
+++ b/app-portage/recover-broken-vdb/recover-broken-vdb-1.0.0-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -24,6 +24,8 @@ SLOT="0"
# Require latest version of pax-utils to avoid users breaking their systems again
# The tool itself works fine with older versions
-RDEPEND=">=app-misc/pax-utils-1.3.3
+RDEPEND="
+ >=app-misc/pax-utils-1.3.5
sys-apps/file
- $(python_gen_cond_dep 'sys-apps/portage[${PYTHON_USEDEP}]')"
+ $(python_gen_cond_dep 'sys-apps/portage[${PYTHON_USEDEP}]')
+"
diff --git a/app-portage/recover-broken-vdb/recover-broken-vdb-9999.ebuild b/app-portage/recover-broken-vdb/recover-broken-vdb-9999.ebuild
index 6bf736875162..14ee0a7a98bc 100644
--- a/app-portage/recover-broken-vdb/recover-broken-vdb-9999.ebuild
+++ b/app-portage/recover-broken-vdb/recover-broken-vdb-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -24,6 +24,8 @@ SLOT="0"
# Require latest version of pax-utils to avoid users breaking their systems again
# The tool itself works fine with older versions
-RDEPEND=">=app-misc/pax-utils-1.3.3
+RDEPEND="
+ >=app-misc/pax-utils-1.3.5
sys-apps/file
- $(python_gen_cond_dep 'sys-apps/portage[${PYTHON_USEDEP}]')"
+ $(python_gen_cond_dep 'sys-apps/portage[${PYTHON_USEDEP}]')
+"