summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/ufed/ufed-9999.ebuild')
-rw-r--r--app-portage/ufed/ufed-9999.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/app-portage/ufed/ufed-9999.ebuild b/app-portage/ufed/ufed-9999.ebuild
index 74f9f4a789b4..08ff84575c6c 100644
--- a/app-portage/ufed/ufed-9999.ebuild
+++ b/app-portage/ufed/ufed-9999.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/ufed.git"
else
SRC_URI="https://gitweb.gentoo.org/proj/ufed.git/snapshot/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
-inherit autotools out-of-source
+inherit autotools flag-o-matic out-of-source
DESCRIPTION="Gentoo Linux USE flags editor"
HOMEPAGE="https://wiki.gentoo.org/wiki/Ufed"
@@ -23,8 +23,8 @@ IUSE=""
RDEPEND="
dev-lang/perl
sys-libs/ncurses:0="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
@@ -35,3 +35,11 @@ src_prepare() {
eautoreconf
}
+
+my_src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/854864
+ filter-lto
+
+ default
+}