summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/dash/dash-0.5.11.2.ebuild')
-rw-r--r--app-shells/dash/dash-0.5.11.2.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/app-shells/dash/dash-0.5.11.2.ebuild b/app-shells/dash/dash-0.5.11.2.ebuild
index 9482c8379d58..1d6d3b324589 100644
--- a/app-shells/dash/dash-0.5.11.2.ebuild
+++ b/app-shells/dash/dash-0.5.11.2.ebuild
@@ -32,9 +32,10 @@ src_prepare() {
}
src_configure() {
- # don't redefine stat on Solaris
if [[ ${CHOST} == *-solaris* ]] ; then
+ # don't redefine stat, open, dirent, etc. on Solaris
export ac_cv_func_stat64=yes
+ export ac_cv_func_open64=yes
# if your headers strictly adhere to POSIX, you'll need this too
[[ ${CHOST##*solaris2.} -le 10 ]] && append-cppflags -DNAME_MAX=255