summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/fish/fish-2.7.1.ebuild')
-rw-r--r--app-shells/fish/fish-2.7.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-shells/fish/fish-2.7.1.ebuild b/app-shells/fish/fish-2.7.1.ebuild
index 657ee7b3e84c..06afa49de51f 100644
--- a/app-shells/fish/fish-2.7.1.ebuild
+++ b/app-shells/fish/fish-2.7.1.ebuild
@@ -27,6 +27,8 @@ DEPEND="
test? ( dev-tcltk/expect )
"
+PATCHES=( "${FILESDIR}/${P}-fix-printf-o-handling-on-ppc.patch" )
+
S="${WORKDIR}/${MY_P}"
src_configure() {
@@ -48,7 +50,11 @@ src_install() {
}
src_test() {
- emake V=1 test
+ if has_version ~${CATEGORY}/${P} ; then
+ emake -j1 V=1 SHOW_INTERACTIVE_LOG=1 test
+ else
+ ewarn "Some tests only work when the package is already installed"
+ fi
}
pkg_postinst() {