summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/Manifest5
-rw-r--r--app-text/asciidoc/asciidoc-10.2.0.ebuild47
-rw-r--r--app-text/asciidoc/asciidoc-8.6.10.ebuild88
-rw-r--r--app-text/asciidoc/asciidoc-8.6.10_p20181016.ebuild92
-rw-r--r--app-text/asciidoc/asciidoc-8.6.9-r2.ebuild77
-rw-r--r--app-text/asciidoc/asciidoc-8.6.9-r6.ebuild86
-rw-r--r--app-text/asciidoc/asciidoc-9.1.0.ebuild84
-rw-r--r--app-text/asciidoc/metadata.xml23
8 files changed, 141 insertions, 361 deletions
diff --git a/app-text/asciidoc/Manifest b/app-text/asciidoc/Manifest
index 31865ddc7063..ba6c37529be0 100644
--- a/app-text/asciidoc/Manifest
+++ b/app-text/asciidoc/Manifest
@@ -1,3 +1,2 @@
-DIST asciidoc-8.6.10.tar.gz 577208 BLAKE2B 320724c3e2306e14212a4e32f09fb735861f9b0126ce86695c6b5840b69f94d0e5befbbfc355006a10d13d34e8ed3582f0bfb678744654a7d2040555016b1681 SHA512 6ecc86977baaf1c756691e3f661e43ef2bb24e606898f6075bfa6f174d1fdc5e77d00853ffe014847e295364349d6ad34f3b8209cb97870e0233012fc38a281a
-DIST asciidoc-8.6.10_p20181016.tar.gz 576694 BLAKE2B 4d255606675346d00ab03398bf48cb30d357f9f9366944e4faf66ae4c96dafce49acdd930fc848f3dbb2d704a004bb5815d17b53416a76c8368a92e4716328b2 SHA512 801f360b0c444e932f1c50897d446de0ec3f0fb2206080b5aa6dda396fede96065f7bb629a84c8a8e40c5d8897f305fdb1877512f04ae757f3b142fd3a7305d0
-DIST asciidoc-8.6.9.tar.gz 907253 BLAKE2B 45db42abd9ec73f6d3b20fc755bdd501eab1503bd8d5d6bb6b7d66c442cf8bcd47ee4325dbb572bdcfd01168ef1bccc3430ee7c545e7b3a6715b8ebf09516ad9 SHA512 1984482010dbd35c3a1def67f4915ce83ecfc29a7463f84aa312107d7a9ff647978f57615462c65e885bea424eed89a212df728cc3acd3c63df1c763dfa5e955
+DIST asciidoc-10.2.0.tar.gz 216824 BLAKE2B 500038d655f820fe89048bbff683ae029c7044de839ae4f9ec4666b843585511c99bbc1991ec1764262f33c55b08845661fc1e62eb21bb3250d3168e369928ff SHA512 2f83c7f6d1d0a34948035347833ca59841de1271e8d008b4c4a43a7a8273b230148e6f51ee8f6e2dc702460e27c495037fbe2d6d43195b70bf3447ad86390d28
+DIST asciidoc-9.1.0.new.tar.gz 1249958 BLAKE2B 0a98f58f7604f84d704092313c38563634bad5d697d60d02760f3be1d2a78a97ee2488dda3a9918b02e0062710175c6513d600f3fbd850fe700bf3fa917a3980 SHA512 c30854a936228fe5bcf2f9305741fbc4b17ef088b2fa637d5f3b19c7803306085634fb71146f0b089c2fad01f986da71a4fae364139f520c0906525317c0c4a6
diff --git a/app-text/asciidoc/asciidoc-10.2.0.ebuild b/app-text/asciidoc/asciidoc-10.2.0.ebuild
new file mode 100644
index 000000000000..e9bcfe8888cd
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-10.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+inherit distutils-r1 optfeature readme.gentoo-r1 pypi
+
+DESCRIPTION="A plain text human readable/writable document format"
+HOMEPAGE="https://asciidoc.org/ https://github.com/asciidoc-py/asciidoc-py/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ dev-libs/libxml2:2
+"
+
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
+src_install() {
+ distutils-r1_src_install
+
+ # TODO: Consider using Debian patch to allow /usr/share?
+ insinto /usr/share/asciidoc
+ doins -r asciidoc/resources/.
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "music filter support" "media-sound/lilypond virtual/imagemagick-tools"
+ optfeature "source filter support" "dev-util/source-highlight dev-python/pygments app-text/highlight"
+ optfeature "latex filter support" "dev-texlive/texlive-latex app-text/dvipng" "dev-texlive/texlive-latex app-text/dvisvgm"
+ optfeature "graphviz filter support" "media-gfx/graphviz"
+}
diff --git a/app-text/asciidoc/asciidoc-8.6.10.ebuild b/app-text/asciidoc/asciidoc-8.6.10.ebuild
deleted file mode 100644
index dfcb6964d773..000000000000
--- a/app-text/asciidoc/asciidoc-8.6.10.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit autotools python-single-r1 readme.gentoo-r1
-
-DESCRIPTION="A plain text human readable/writable document format"
-HOMEPAGE="http://asciidoc.org/"
-SRC_URI="https://github.com/asciidoc/asciidoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples graphviz highlight test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- app-text/docbook-xml-dtd:4.5
- >=app-text/docbook-xsl-stylesheets-1.75
- dev-libs/libxslt
- ${PYTHON_DEPS}
- graphviz? ( media-gfx/graphviz )
- highlight? (
- || (
- dev-util/source-highlight
- dev-python/pygments[${PYTHON_USEDEP}]
- app-text/highlight
- )
- )"
-DEPEND="
- test? (
- app-text/dvipng
- dev-texlive/texlive-latex
- dev-util/source-highlight
- media-gfx/graphviz
- media-gfx/imagemagick
- media-sound/lilypond
- ${PYTHON_DEPS}
- )"
-
-DOC_CONTENTS="
-If you are going to use a2x, please also look at a2x(1) under
-REQUISITES for a list of runtime dependencies.
-"
-
-src_prepare() {
- default
- # Only needed for prefix - harmless (does nothing) otherwise
- sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
- "${S}/asciidoc.py" || die
-
- eautoreconf
-}
-
-src_configure() {
- econf --sysconfdir="${EPREFIX}"/usr/share
-}
-
-src_test() {
- local -x ASCIIDOC_PY=asciidoc.py
- "${EPYTHON}" tests/test${PN}.py update || die
- "${EPYTHON}" tests/test${PN}.py run || die
-}
-
-src_install() {
- default
- python_fix_shebang "${ED%/}"/usr/bin/*.py
-
- readme.gentoo_create_doc
- dodoc BUGS.txt CHANGELOG.txt README.asciidoc docbook-xsl/asciidoc-docbook-xsl.txt \
- dblatex/dblatex-readme.txt filters/code/code-filter-readme.txt
-
- # Below results in some files being installed twice in different locations, but they are
- # in the right place, uncompressed, and there won't be any broken links. See bug #483336
- if use examples; then
- # examples/website is full of relative symlinks,
- # deref them for copying, which dodoc doesn't do
- cp -rL examples/website "${ED%/}"/usr/share/doc/${PF}/examples || die
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/app-text/asciidoc/asciidoc-8.6.10_p20181016.ebuild b/app-text/asciidoc/asciidoc-8.6.10_p20181016.ebuild
deleted file mode 100644
index 5474f073229d..000000000000
--- a/app-text/asciidoc/asciidoc-8.6.10_p20181016.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
-
-inherit autotools python-single-r1 readme.gentoo-r1
-
-DESCRIPTION="A plain text human readable/writable document format"
-HOMEPAGE="http://asciidoc.org/ https://github.com/asciidoc/asciidoc-py3/"
-MY_COMMIT="618f6e6f6b558ed1e5f2588cd60a5a6b4f881ca0"
-SRC_URI="https://github.com/${PN}/${PN}-py3/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples graphviz highlight test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- app-text/docbook-xml-dtd:4.5
- >=app-text/docbook-xsl-stylesheets-1.75
- dev-libs/libxslt
- dev-libs/libxml2
- ${PYTHON_DEPS}
- graphviz? ( media-gfx/graphviz )
- highlight? (
- || (
- dev-util/source-highlight
- dev-python/pygments[${PYTHON_USEDEP}]
- app-text/highlight
- )
- )"
-DEPEND="
- test? (
- app-text/dvipng
- dev-texlive/texlive-latex
- dev-util/source-highlight
- media-gfx/graphviz
- media-gfx/imagemagick
- media-sound/lilypond
- ${PYTHON_DEPS}
- )"
-
-DOC_CONTENTS="
-If you are going to use a2x, please also look at a2x(1) under
-REQUISITES for a list of runtime dependencies.
-"
-
-S="${WORKDIR}/${PN}-py3-${MY_COMMIT}"
-
-src_prepare() {
- default
- # Only needed for prefix - harmless (does nothing) otherwise
- sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
- "${S}/asciidoc.py" || die
-
- eautoreconf
-}
-
-src_configure() {
- econf --sysconfdir="${EPREFIX}"/usr/share
-}
-
-src_test() {
- local -x ASCIIDOC_PY=asciidoc.py
- "${EPYTHON}" tests/test${PN}.py update || die
- "${EPYTHON}" tests/test${PN}.py run || die
-}
-
-src_install() {
- default
- python_fix_shebang "${ED}"/usr/bin/*.py
-
- readme.gentoo_create_doc
- dodoc BUGS.txt CHANGELOG.txt README.asciidoc docbook-xsl/asciidoc-docbook-xsl.txt \
- dblatex/dblatex-readme.txt filters/code/code-filter-readme.txt
-
- # Below results in some files being installed twice in different locations, but they are
- # in the right place, uncompressed, and there won't be any broken links. See bug #483336
- if use examples; then
- # examples/website is full of relative symlinks,
- # deref them for copying, which dodoc doesn't do
- cp -rL examples/website "${ED%/}"/usr/share/doc/${PF}/examples || die
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/app-text/asciidoc/asciidoc-8.6.9-r2.ebuild b/app-text/asciidoc/asciidoc-8.6.9-r2.ebuild
deleted file mode 100644
index 1a8c91dd30a4..000000000000
--- a/app-text/asciidoc/asciidoc-8.6.9-r2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit readme.gentoo python-single-r1
-
-DESCRIPTION="A plain text human readable/writable document format"
-HOMEPAGE="http://asciidoc.org/"
-SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples graphviz highlight test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND=">=app-text/docbook-xsl-stylesheets-1.75
- dev-libs/libxslt
- graphviz? ( media-gfx/graphviz )
- app-text/docbook-xml-dtd:4.5
- highlight? ( || ( dev-util/source-highlight \
- dev-python/pygments[${PYTHON_USEDEP}] \
- app-text/highlight )
- )
- ${PYTHON_DEPS}
-"
-DEPEND="test? ( dev-util/source-highlight
- media-sound/lilypond
- media-gfx/imagemagick
- dev-texlive/texlive-latex
- app-text/dvipng
- media-gfx/graphviz
- ${PYTHON_DEPS} )
-"
-
-DOC_CONTENTS="
-If you are going to use a2x, please also look at a2x(1) under
-REQUISITES for a list of runtime dependencies.
-"
-
-src_prepare() {
- # Only needed for prefix - harmless (does nothing) otherwise
- sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
- "${S}/asciidoc.py" || die
-}
-
-src_configure() {
- econf --sysconfdir="${EPREFIX}"/usr/share
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- python_fix_shebang "${ED}"/usr/bin/*.py
-
- readme.gentoo_create_doc
- dodoc BUGS CHANGELOG README docbook-xsl/asciidoc-docbook-xsl.txt \
- dblatex/dblatex-readme.txt filters/code/code-filter-readme.txt
-
- # Below results in some files being installed twice in different locations, but they are in the right place,
- # uncompressed, and there won't be any broken links. See bug #483336.
- if use examples; then
- cp -rL examples/website "${D}"/usr/share/doc/${PF}/examples || die
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-src_test() {
- cd tests || die
- local -x ASCIIDOC_PY=../asciidoc.py
- "${PYTHON}" test${PN}.py update || die
- "${PYTHON}" test${PN}.py run || die
-}
diff --git a/app-text/asciidoc/asciidoc-8.6.9-r6.ebuild b/app-text/asciidoc/asciidoc-8.6.9-r6.ebuild
deleted file mode 100644
index 06458cb42e0e..000000000000
--- a/app-text/asciidoc/asciidoc-8.6.9-r6.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit python-single-r1 readme.gentoo-r1
-
-DESCRIPTION="A plain text human readable/writable document format"
-HOMEPAGE="http://asciidoc.org/"
-SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples graphviz highlight test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- app-text/docbook-xml-dtd:4.5
- >=app-text/docbook-xsl-stylesheets-1.75
- dev-libs/libxslt
- ${PYTHON_DEPS}
- graphviz? ( media-gfx/graphviz )
- highlight? (
- || (
- dev-util/source-highlight
- dev-python/pygments[${PYTHON_USEDEP}]
- app-text/highlight
- )
- )"
-DEPEND="
- test? (
- app-text/dvipng
- dev-texlive/texlive-latex
- dev-util/source-highlight
- media-gfx/graphviz
- media-gfx/imagemagick
- media-sound/lilypond
- ${PYTHON_DEPS}
- )"
-
-DOC_CONTENTS="
-If you are going to use a2x, please also look at a2x(1) under
-REQUISITES for a list of runtime dependencies.
-"
-
-src_prepare() {
- default
- # Only needed for prefix - harmless (does nothing) otherwise
- sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
- "${S}/asciidoc.py" || die
-}
-
-src_configure() {
- econf --sysconfdir="${EPREFIX}"/usr/share
-}
-
-src_test() {
- local -x ASCIIDOC_PY=asciidoc.py
- "${EPYTHON}" tests/test${PN}.py update || die
- "${EPYTHON}" tests/test${PN}.py run || die
-}
-
-src_install() {
- default
- python_fix_shebang "${ED%/}"/usr/bin/*.py
-
- readme.gentoo_create_doc
- dodoc BUGS CHANGELOG README docbook-xsl/asciidoc-docbook-xsl.txt \
- dblatex/dblatex-readme.txt filters/code/code-filter-readme.txt
-
- # Below results in some files being installed twice in different locations, but they are
- # in the right place, uncompressed, and there won't be any broken links. See bug #483336
- if use examples; then
- # examples/website is full of relative symlinks,
- # deref them for copying, which dodoc doesn't do
- cp -rL examples/website "${ED%/}"/usr/share/doc/${PF}/examples || die
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/app-text/asciidoc/asciidoc-9.1.0.ebuild b/app-text/asciidoc/asciidoc-9.1.0.ebuild
new file mode 100644
index 000000000000..075821590784
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-9.1.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..10} pypy3 )
+
+inherit autotools optfeature python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="A plain text human readable/writable document format"
+HOMEPAGE="https://asciidoc.org/ https://github.com/asciidoc-py/asciidoc-py/"
+SRC_URI="https://github.com/asciidoc-py/asciidoc-py/releases/download/${PV}/${P}.tar.gz -> ${P}.new.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ dev-libs/libxml2:2
+ "
+DEPEND="
+ test? (
+ ${PYTHON_DEPS}
+ app-text/dvipng
+ app-text/dvisvgm
+ dev-texlive/texlive-latex
+ dev-util/source-highlight
+ media-gfx/graphviz
+ media-gfx/imagemagick[png]
+ media-sound/lilypond
+ )"
+
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
+DOCS=( BUGS.txt CHANGELOG.txt README.asciidoc
+ docbook-xsl/asciidoc-docbook-xsl.txt dblatex/dblatex-readme.txt
+ filters/code/code-filter-readme.txt )
+
+src_prepare() {
+ default
+ # Only needed for prefix - harmless (does nothing) otherwise
+ sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
+ asciidoc.py || die
+
+ # enforce usage of the configured version of Python
+ sed -i -e "s:python3:${EPYTHON}:" Makefile.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/usr/share
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ emake DESTDIR="${D}" docs
+ fi
+
+ python_fix_shebang "${ED}"/usr/bin/*.py
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "\"music\" filter support" "media-sound/lilypond media-gfx/imagemagick"
+ optfeature "\"source\" filter support" dev-util/source-highlight dev-python/pygments app-text/highlight
+ optfeature "\"latex\" filter support" "dev-texlive/texlive-latex app-text/dvipng" "dev-texlive/texlive-latex app-text/dvisvgm"
+ optfeature "\"graphviz\" filter support" media-gfx/graphviz
+}
diff --git a/app-text/asciidoc/metadata.xml b/app-text/asciidoc/metadata.xml
index 33454ff9d090..5e3bb3ff9c88 100644
--- a/app-text/asciidoc/metadata.xml
+++ b/app-text/asciidoc/metadata.xml
@@ -1,18 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>marcec@gmx.de</email>
- <name>Marc Joliet</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <use>
- <flag name="highlight">Enable source code highlighting</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">asciidoc</remote-id>
- </upstream>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">asciidoc</remote-id>
+ <remote-id type="github">asciidoc-py/asciidoc-py</remote-id>
+ <remote-id type="pypi">asciidoc</remote-id>
+ <bugs-to>https://github.com/asciidoc-py/asciidoc-py/issues</bugs-to>
+ </upstream>
</pkgmetadata>