summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/barcode/files')
-rw-r--r--app-text/barcode/files/0.98-info.patch14
-rw-r--r--app-text/barcode/files/barcode-0.99-fno-common.patch25
-rw-r--r--app-text/barcode/files/barcode-0.99-install-static-lib.patch13
-rw-r--r--app-text/barcode/files/barcode-0.99-not-a-literal-string.patch19
4 files changed, 57 insertions, 14 deletions
diff --git a/app-text/barcode/files/0.98-info.patch b/app-text/barcode/files/0.98-info.patch
deleted file mode 100644
index 740458f88ed4..000000000000
--- a/app-text/barcode/files/0.98-info.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- doc/barcode.info.old 2003-10-26 19:08:39.000000000 -0800
-+++ doc/barcode.info 2003-10-26 19:58:42.179447512 -0800
-@@ -1,6 +1,11 @@
- This is barcode.info, produced by makeinfo version 4.0 from
- barcode.texinfo.
-
-+INFO-DIR-SECTION Miscellaneous
-+START-INFO-DIR-ENTRY
-+* Barcode: (barcode). Barcode generation library.
-+END-INFO-DIR-ENTRY
-+
- This file is the User's Manual for the barcode library (version
- 0.98).
-
diff --git a/app-text/barcode/files/barcode-0.99-fno-common.patch b/app-text/barcode/files/barcode-0.99-fno-common.patch
new file mode 100644
index 000000000000..5abb8a26824f
--- /dev/null
+++ b/app-text/barcode/files/barcode-0.99-fno-common.patch
@@ -0,0 +1,25 @@
+Taken from: https://sources.debian.org/patches/barcode/0.99-4/0006-Fix-FTBFS-with-gcc-10.patch/
+Author: https://sources.debian.org/patches/barcode/0.99-4/0006-Fix-FTBFS-with-gcc-10.patch/
+--- a/barcode.h
++++ b/barcode.h
+@@ -123,6 +123,6 @@ extern int Barcode_Version(char *versionname);
+ }
+ #endif
+
+-int streaming;
++extern int streaming;
+
+ #endif /* _BARCODE_H_ */
+diff --git a/library.c b/library.c
+index 30946ff..5390a2b 100644
+--- a/library.c
++++ b/library.c
+@@ -30,6 +30,8 @@
+ #endif
+ #include <errno.h>
+
++int streaming;
++
+ /*
+ * This function allocates a barcode structure and strdup()s the
+ * text string. It returns NULL in case of error
diff --git a/app-text/barcode/files/barcode-0.99-install-static-lib.patch b/app-text/barcode/files/barcode-0.99-install-static-lib.patch
new file mode 100644
index 000000000000..44d32d059ce9
--- /dev/null
+++ b/app-text/barcode/files/barcode-0.99-install-static-lib.patch
@@ -0,0 +1,13 @@
+--- barcode-0.99_orig/Makefile.am 2020-12-06 15:39:43.270943391 +0100
++++ barcode-0.99/Makefile.am 2020-12-06 15:40:26.723942515 +0100
+@@ -25,7 +25,9 @@
+
+ bin_PROGRAMS = barcode sample
+
+-noinst_LTLIBRARIES = libbarcode.la
++lib_LTLIBRARIES = libbarcode.la
++
++include_HEADERS = barcode.h lib/gettext.h
+
+ ACLOCAL_AMFLAGS = -I m4
+
diff --git a/app-text/barcode/files/barcode-0.99-not-a-literal-string.patch b/app-text/barcode/files/barcode-0.99-not-a-literal-string.patch
new file mode 100644
index 000000000000..63b49d25c058
--- /dev/null
+++ b/app-text/barcode/files/barcode-0.99-not-a-literal-string.patch
@@ -0,0 +1,19 @@
+Taken from: https://lists.gnu.org/archive/html/bug-barcode/2021-09/msg00000.html
+Author: https://lists.gnu.org/archive/html/bug-barcode/2021-09/msg00000.html
+---
+ plessey.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/plessey.c b/plessey.c
+index 2f59e39..3089a3c 100644
+--- a/plessey.c
++++ b/plessey.c
+@@ -149,7 +149,7 @@ int Barcode_pls_encode(struct Barcode_Item *bc)
+ checkptr[i+j] ^= check[j];
+ }
+ for (i = 0; i < 8; i++) {
+- sprintf(ptr, patterns[checkptr[strlen(text) * 4 + i]]);
++ sprintf(ptr, "%s", patterns[checkptr[strlen(text) * 4 + i]]);
+ ptr += 2;
+ }
+ fprintf(stderr, _("CRC: "));