summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/binfind/binfind-0.0.3.ebuild')
-rw-r--r--app-text/binfind/binfind-0.0.3.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/app-text/binfind/binfind-0.0.3.ebuild b/app-text/binfind/binfind-0.0.3.ebuild
index 0285f93dbe53..fce82cc6b67d 100644
--- a/app-text/binfind/binfind-0.0.3.ebuild
+++ b/app-text/binfind/binfind-0.0.3.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit autotools
DESCRIPTION="Search files for a byte sequence specified on the command line"
HOMEPAGE="https://www.lith.at/binfind/"
@@ -9,5 +11,14 @@ SRC_URI="https://www.lith.at/binfind/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
+KEYWORDS="~amd64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf #870832
+}