summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/cuneiform/cuneiform-1.1.0-r3.ebuild')
-rw-r--r--app-text/cuneiform/cuneiform-1.1.0-r3.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-text/cuneiform/cuneiform-1.1.0-r3.ebuild b/app-text/cuneiform/cuneiform-1.1.0-r3.ebuild
index 3874e69f95e6..f1c79faecb48 100644
--- a/app-text/cuneiform/cuneiform-1.1.0-r3.ebuild
+++ b/app-text/cuneiform/cuneiform-1.1.0-r3.ebuild
@@ -1,16 +1,17 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake flag-o-matic
PV_MAJ=$(ver_cut 1-2)
MY_P=${PN}-linux-${PV}
-DESCRIPTION="An enterprise quality OCR engine by Cognitive Technologies"
+DESCRIPTION="Enterprise quality OCR engine by Cognitive Technologies"
HOMEPAGE="https://launchpad.net/cuneiform-linux"
SRC_URI="https://launchpad.net/${PN}-linux/${PV_MAJ}/${PV_MAJ}/+download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
@@ -22,8 +23,6 @@ RDEPEND="
graphicsmagick? ( media-gfx/graphicsmagick:= )"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/${MY_P}
-
PATCHES=(
# From Fedora
"${FILESDIR}"/${P}-c-assert.patch
@@ -33,6 +32,7 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc6.patch
"${FILESDIR}"/${P}-gcc7.patch
"${FILESDIR}"/${P}-typos.patch
+ "${FILESDIR}"/${P}-gcc11.patch
)
src_prepare() {