summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ding/ding-1.9.ebuild')
-rw-r--r--app-text/ding/ding-1.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/ding/ding-1.9.ebuild b/app-text/ding/ding-1.9.ebuild
new file mode 100644
index 000000000000..7b7ecc39822e
--- /dev/null
+++ b/app-text/ding/ding-1.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+DESCRIPTION="Tk based dictionary (German-English) (incl. dictionary itself)"
+HOMEPAGE="https://www-user.tu-chemnitz.de/~fri/ding/"
+SRC_URI="http://wftp.tu-chemnitz.de/pub/Local/urz/ding/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/tk-8.3"
+
+src_install() {
+ dobin ding
+ insinto /usr/share/dict
+ doins de-en.txt
+ doman ding.1
+ dodoc CHANGES README.md
+
+ doicon ding.png
+ domenu ding.desktop
+}