summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/flpsed')
-rw-r--r--app-text/flpsed/Manifest3
-rw-r--r--app-text/flpsed/files/flpsed-0.7.2-desktop.patch8
-rw-r--r--app-text/flpsed/flpsed-0.7.0.ebuild22
-rw-r--r--app-text/flpsed/flpsed-0.7.2.ebuild35
-rw-r--r--app-text/flpsed/flpsed-0.7.3.ebuild35
-rw-r--r--app-text/flpsed/metadata.xml5
6 files changed, 108 insertions, 0 deletions
diff --git a/app-text/flpsed/Manifest b/app-text/flpsed/Manifest
new file mode 100644
index 000000000000..ac0d6ba6989e
--- /dev/null
+++ b/app-text/flpsed/Manifest
@@ -0,0 +1,3 @@
+DIST flpsed-0.7.0.tar.gz 119159 SHA256 aedb5c96dfdcbe260d133f9b674a98d9948a1614d76ce623acb57503f2850b38 SHA512 0d5112f4e4f4401a1942767d0de1b38cffbc37e0f798b59e9371c37892c6d2e2448146baff2737e416ab9ec5d96963728918d4a49fc059ac1119d8ac946db59e WHIRLPOOL a52dd393b2a1aef829ce8d1f6ef7b9a9c95f08da39c4dec261943ea37abf2bb319cbb53bd76642d0b6d1e47f520b4236995528be1010ebc2ffa41b4aaa850edd
+DIST flpsed-0.7.2.tar.gz 146678 SHA256 c8c5b54fd21d0b2af2c11bcd7e68f0533c183ba0e9b24f8923dd64ab1eb56284 SHA512 d0e2f7d34e48555d74f58e9df16fa6d29e8fda1fb4c6e58ccdda512f25d7f7ee0e3657e11564cdb9dec483c14f42078636430e5ec987165cc7c6c5de8990984d WHIRLPOOL e7e713070463a99301fbceba62700c3b09ec8131a96d569305cffeb26664148254b84ace75a61a91672e939e568436821b0c054e9d70d7f4a3f4463699887007
+DIST flpsed-0.7.3.tar.gz 146788 SHA256 b70bb751bd70af9893ae2369f0789fd79729d0d6d1fee6e0522c4e6f55c7cf6e SHA512 b0a8bf2ea08630d280f83f7c32b4574ba4cf7fd989943492e77d1b73c8d83c81a5df40e64bfff744b5518de845eba21119242ff752e16b20816b225ccb7c3321 WHIRLPOOL b9b8e6e98e9685093303e88f1356e97faded49da6e216db0fbc164300f1b6c2baef2722e0ffc494fefe63796d67768062d8b5ca47b59955f65ea47f26f6892fc
diff --git a/app-text/flpsed/files/flpsed-0.7.2-desktop.patch b/app-text/flpsed/files/flpsed-0.7.2-desktop.patch
new file mode 100644
index 000000000000..55a402bf142c
--- /dev/null
+++ b/app-text/flpsed/files/flpsed-0.7.2-desktop.patch
@@ -0,0 +1,8 @@
+--- flpsed-0.7.2/flpsed.desktop
++++ flpsed-0.7.2/flpsed.desktop
+@@ -11,4 +11,4 @@
+ StartupNotify=true
+ Categories=Graphics;
+ MimeType=application/postscript;application/pdf;
+-Keywords=flpsed;pdf annotator;fltk
++Keywords=flpsed;pdf annotator;fltk;
diff --git a/app-text/flpsed/flpsed-0.7.0.ebuild b/app-text/flpsed/flpsed-0.7.0.ebuild
new file mode 100644
index 000000000000..486cea1eb43d
--- /dev/null
+++ b/app-text/flpsed/flpsed-0.7.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Pseudo PostScript editor"
+HOMEPAGE="http://www.ecademix.com/JohannesHofmann/"
+SRC_URI="http://www.ecademix.com/JohannesHofmann/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ >=x11-libs/fltk-1.3.0:1
+ app-text/ghostscript-gpl[X]"
+
+DEPEND="${RDEPEND}"
diff --git a/app-text/flpsed/flpsed-0.7.2.ebuild b/app-text/flpsed/flpsed-0.7.2.ebuild
new file mode 100644
index 000000000000..5bfb081d6ed9
--- /dev/null
+++ b/app-text/flpsed/flpsed-0.7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Pseudo PostScript editor"
+HOMEPAGE="http://www.ecademix.com/JohannesHofmann/"
+SRC_URI="http://www.ecademix.com/JohannesHofmann/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ >=x11-libs/fltk-1.3.0:1
+ app-text/ghostscript-gpl[X]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-desktop.patch
+}
+
+src_install() {
+ default
+
+ doicon ${PN}.png
+ doicon -s scalable ${PN}.svg
+ domenu ${PN}.desktop
+}
diff --git a/app-text/flpsed/flpsed-0.7.3.ebuild b/app-text/flpsed/flpsed-0.7.3.ebuild
new file mode 100644
index 000000000000..3580e00da09a
--- /dev/null
+++ b/app-text/flpsed/flpsed-0.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Pseudo PostScript editor"
+HOMEPAGE="http://www.ecademix.com/JohannesHofmann/"
+SRC_URI="http://www.ecademix.com/JohannesHofmann/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ >=x11-libs/fltk-1.3.0:1
+ app-text/ghostscript-gpl[X]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.7.2-desktop.patch
+}
+
+src_install() {
+ default
+
+ doicon ${PN}.png
+ doicon -s scalable ${PN}.svg
+ domenu ${PN}.desktop
+}
diff --git a/app-text/flpsed/metadata.xml b/app-text/flpsed/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/app-text/flpsed/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>