summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/html2text/html2text-2.1.1.ebuild')
-rw-r--r--app-text/html2text/html2text-2.1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-text/html2text/html2text-2.1.1.ebuild b/app-text/html2text/html2text-2.1.1.ebuild
new file mode 100644
index 000000000000..2a2be554d110
--- /dev/null
+++ b/app-text/html2text/html2text-2.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/grobian/html2text.git"
+else
+ SRC_URI="https://github.com/grobian/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+DESCRIPTION="HTML to text converter"
+HOMEPAGE="https://github.com/grobian/html2text"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_configure() {
+ # non-autoconf configure
+ tc-export CXX
+ default
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ MANDIR="${EPREFIX}/usr/share/man" \
+ DOCDIR="${EPREFIX}/usr/share/doc/${P}" \
+ install
+}