summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/htmlc/htmlc-2.40.0.ebuild')
-rw-r--r--app-text/htmlc/htmlc-2.40.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-text/htmlc/htmlc-2.40.0.ebuild b/app-text/htmlc/htmlc-2.40.0.ebuild
new file mode 100644
index 000000000000..942d0f5c4588
--- /dev/null
+++ b/app-text/htmlc/htmlc-2.40.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Override version: 2.4.0 > 2.21.0 so we name it 2.40.0
+MY_P="${P/0[.]/.}"
+
+DESCRIPTION="HTML template files expander"
+HOMEPAGE="http://htmlc.inria.fr/"
+SRC_URI="http://htmlc.inria.fr/${MY_P}.tgz"
+
+LICENSE="htmlc"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="+ocamlopt"
+# Files for the tests are missing...
+#RESTRICT="test"
+
+DEPEND=">=dev-lang/ocaml-3.11.2:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ ./configure \
+ --install-root-dir "${ED}usr" \
+ || die
+}
+
+src_compile() {
+ if use ocamlopt ; then
+ emake bin
+ else
+ emake byt
+ fi
+}
+
+src_install() {
+ if use ocamlopt ; then
+ emake installbin
+ else
+ emake installbyt
+ fi
+ emake MANDIR='$(PREFIXINSTALLDIR)/share/man/man$(MANEXT)' installman
+ dodoc README Announce* CHANGES
+}