summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/jo/jo-9999.ebuild')
-rw-r--r--app-text/jo/jo-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/jo/jo-9999.ebuild b/app-text/jo/jo-9999.ebuild
new file mode 100644
index 000000000000..162d12aebd86
--- /dev/null
+++ b/app-text/jo/jo-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="JSON output from a shell"
+HOMEPAGE="https://github.com/jpmens/jo"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jpmens/${PN}"
+else
+ SRC_URI="https://github.com/jpmens/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export bashcompdir=$(get_bashcompdir)
+ default
+}
+
+src_install() {
+ default
+ mv "${D}"$(get_bashcompdir)/jo{.bash,} || die
+}