summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/kding/kding-0.6-r2.ebuild')
-rw-r--r--app-text/kding/kding-0.6-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/kding/kding-0.6-r2.ebuild b/app-text/kding/kding-0.6-r2.ebuild
new file mode 100644
index 000000000000..2111fe24ffe4
--- /dev/null
+++ b/app-text/kding/kding-0.6-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="de"
+inherit kde4-base
+
+DESCRIPTION="KDE port of Ding, a dictionary lookup program"
+HOMEPAGE="http://www.rexi.org/software/kding/"
+SRC_URI="http://www.rexi.org/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+PATCHES=( "${FILESDIR}"/${P}-dtd.patch )
+
+src_prepare() {
+ sed -e "/Encoding=UTF-8/d" \
+ -i resources/kding.desktop || die "fixing .desktop file failed"
+
+ kde4-base_src_prepare
+}