summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libmspub/libmspub-0.1.4.ebuild')
-rw-r--r--app-text/libmspub/libmspub-0.1.4.ebuild48
1 files changed, 27 insertions, 21 deletions
diff --git a/app-text/libmspub/libmspub-0.1.4.ebuild b/app-text/libmspub/libmspub-0.1.4.ebuild
index 536dfc3cfcd7..78d0df1963cf 100644
--- a/app-text/libmspub/libmspub-0.1.4.ebuild
+++ b/app-text/libmspub/libmspub-0.1.4.ebuild
@@ -1,24 +1,22 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit flag-o-matic
-
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
+inherit autotools flag-o-matic
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libmspub/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
+fi
DESCRIPTION="Library parsing Microsoft Publisher documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libmspub"
-[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libmspub/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
-
-# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86"
-
IUSE="doc static-libs"
RDEPEND="
@@ -27,29 +25,37 @@ RDEPEND="
sys-libs/zlib
"
DEPEND="${RDEPEND}
+ dev-build/libtool
dev-libs/boost
- sys-devel/libtool
+"
+BDEPEND="
virtual/pkgconfig
- doc? ( app-doc/doxygen )
+ doc? ( app-text/doxygen )
"
+PATCHES=( "${FILESDIR}/${P}-gcc10.patch" )
+
src_prepare() {
default
[[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == 9999 ]] && eautoreconf
+
+ # Needed for Clang: stale libtool. bug #832764
+ eautoreconf
}
src_configure() {
- # bug 619044
- append-cxxflags -std=c++14
+ # bug 619044, 932494
+ append-cxxflags -std=c++17
- econf \
- --disable-werror \
- $(use_with doc docs) \
+ local myeconfargs=(
+ --disable-werror
+ $(use_with doc docs)
$(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}