summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libodfgen/libodfgen-0.1.8.ebuild')
-rw-r--r--app-text/libodfgen/libodfgen-0.1.8.ebuild25
1 files changed, 19 insertions, 6 deletions
diff --git a/app-text/libodfgen/libodfgen-0.1.8.ebuild b/app-text/libodfgen/libodfgen-0.1.8.ebuild
index e93e04f93338..13c381630736 100644
--- a/app-text/libodfgen/libodfgen-0.1.8.ebuild
+++ b/app-text/libodfgen/libodfgen-0.1.8.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit edo
+
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://git.code.sf.net/p/libwpd/libodfgen"
inherit autotools git-r3
else
- SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
+ SRC_URI="https://downloads.sourceforge.net/libwpd/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm arm64 ~loong ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
fi
DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
@@ -16,7 +18,8 @@ HOMEPAGE="http://libwpd.sourceforge.net/"
LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
SLOT="0"
-IUSE="doc"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/librevenge
@@ -25,7 +28,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- doc? ( app-doc/doxygen )
+ doc? ( app-text/doxygen )
"
src_prepare() {
@@ -36,7 +39,17 @@ src_prepare() {
src_configure() {
econf \
--disable-static \
- $(use_with doc docs)
+ $(use_with doc docs) \
+ $(use_enable test)
+}
+
+src_test() {
+ cd test || die
+
+ # TODO: send patch upstream to have 'make check' run these
+ while read -r test_name ; do
+ edo "${test_name}"
+ done < <(find . -maxdepth 1 -type f -executable || die)
}
src_install() {