summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libpaper/libpaper-1.1.28.ebuild')
-rw-r--r--app-text/libpaper/libpaper-1.1.28.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/libpaper/libpaper-1.1.28.ebuild b/app-text/libpaper/libpaper-1.1.28.ebuild
new file mode 100644
index 000000000000..99fc37a02be5
--- /dev/null
+++ b/app-text/libpaper/libpaper-1.1.28.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Library for handling paper characteristics"
+HOMEPAGE="https://packages.debian.org/unstable/source/libpaper"
+SRC_URI="mirror://debian/pool/main/libp/libpaper/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+DOCS=( README ChangeLog debian/changelog )
+
+src_prepare() {
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+ default
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ einstalldocs
+
+ dodir /etc
+ (paperconf 2>/dev/null || echo a4) > "${ED}"/etc/papersize \
+ || die "papersize config failed"
+
+ if ! has_version app-text/libpaper ; then
+ echo
+ elog "run e.g. \"paperconfig -p letter\" as root to use letter-pagesizes"
+ echo
+ fi
+}