summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libpaper/libpaper-2.1.3.ebuild')
-rw-r--r--app-text/libpaper/libpaper-2.1.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/libpaper/libpaper-2.1.3.ebuild b/app-text/libpaper/libpaper-2.1.3.ebuild
new file mode 100644
index 000000000000..06d8f269983b
--- /dev/null
+++ b/app-text/libpaper/libpaper-2.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for handling paper characteristics"
+HOMEPAGE="https://github.com/rrthomas/libpaper"
+SRC_URI="https://github.com/rrthomas/libpaper/releases/download/v${PV}/${P}.tar.gz"
+
+# See README.
+# paperspecs is public-domain
+LICENSE="LGPL-2.1+ GPL-3+ public-domain"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # Gnulib false positives #898346
+ # These are all tested without an #include first
+ MIN alignof static_assert
+)
+
+src_configure() {
+ econf --enable-relocatable
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}