summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild')
-rw-r--r--app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild30
1 files changed, 17 insertions, 13 deletions
diff --git a/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild b/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild
index f5697fc876de..0cdcccc08cd3 100644
--- a/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild
+++ b/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild
@@ -1,40 +1,44 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils autotools
+inherit autotools
DESCRIPTION="A set of tools to create and apply patch to XML files using XPath"
HOMEPAGE="http://xmlpatch.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN/lib}/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/${PN/lib}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="test static-libs"
+IUSE="test"
+RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/glib:2
+RDEPEND="
+ dev-libs/glib:2
dev-libs/libxml2"
DEPEND="${RDEPEND}
- test? ( dev-libs/check )
- virtual/pkgconfig"
+ test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
econf \
- $(use_enable static-libs static) \
+ --disable-static \
$(use_with test check)
}
-DOCS=( LEGAL_NOTICE README TODO ChangeLog )
-
src_install() {
default
- find "${D}" -name '*.la' -delete
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}