summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/mathtex/mathtex-1.05.ebuild')
-rw-r--r--app-text/mathtex/mathtex-1.05.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/mathtex/mathtex-1.05.ebuild b/app-text/mathtex/mathtex-1.05.ebuild
new file mode 100644
index 000000000000..47b8d0d3f71b
--- /dev/null
+++ b/app-text/mathtex/mathtex-1.05.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lets you easily embed LaTeX math in your own html pages, blogs, wikis, etc"
+HOMEPAGE="https://www.ctan.org/pkg/mathtex"
+SRC_URI="https://mirrors.ctan.org/support/${PN}.zip -> ${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~riscv x86"
+IUSE="png"
+
+RDEPEND="app-text/dvipng
+ virtual/latex-base"
+BDEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+einfo_run_command() {
+ einfo "${@}"
+ ${@} || die
+}
+
+src_compile() {
+ einfo_run_command $(tc-getCC) \
+ ${CFLAGS} ${LDFLAGS} \
+ -DLATEX=\"/usr/bin/latex\" \
+ -DDVIPNG=\"/usr/bin/dvipng\" \
+ $(use png && echo "-DPNG") \
+ mathtex.c -o mathtex
+}
+
+src_install() {
+ dobin mathtex
+ dodoc README mathtex.html
+}
+
+pkg_postinst() {
+ elog "To use mathtex in your web-pages, just link /usr/bin/mathtex"
+ elog "to your cgi-bin subdirectory!"
+}