summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/nuspell')
-rw-r--r--app-text/nuspell/Manifest2
-rw-r--r--app-text/nuspell/metadata.xml17
-rw-r--r--app-text/nuspell/nuspell-5.1.3.ebuild50
-rw-r--r--app-text/nuspell/nuspell-5.1.4.ebuild50
4 files changed, 119 insertions, 0 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
new file mode 100644
index 000000000000..71de41a24016
--- /dev/null
+++ b/app-text/nuspell/Manifest
@@ -0,0 +1,2 @@
+DIST nuspell-5.1.3.tar.gz 371496 BLAKE2B 7a4aa05b01bd085e0612cf681783cfa2314a3b775c283f7e25c19d6afbb5af74c7ea2ffe149c68ca422383c24bd043e4b5e6b0895a0acd7c376e3d39f253a867 SHA512 72c868f734848be79c7cfb0502298626307213e4f3f422f8e9ee7dac24cb3d79ea55d04ef0443e7107bb11eb545c79a15a8aea8cb056dc2805c23bd5e3292562
+DIST nuspell-5.1.4.tar.gz 371512 BLAKE2B c1c05cc113cf7a6a4b77671f4fe372b2131a6cbcb328d76517bcbb45863e1fd0f27d76597193cae3a5c686d8e0b480fc831e0aa8dbcbf9f9b65420200a13d444 SHA512 f4119b3fe5944be8f5bc35ccff8d7a93b0f4fa9f129bc97a7b96879a11b5b35bd714b41dd209267417e94c5fed45fd3a74b349f94424f4b90bde07d9694d1d7d
diff --git a/app-text/nuspell/metadata.xml b/app-text/nuspell/metadata.xml
new file mode 100644
index 000000000000..11557a865054
--- /dev/null
+++ b/app-text/nuspell/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <longdescription>
+ Spell checker library and command-line program designed for
+ languages with rich morphology and complex word compounding.
+
+ Nuspell is a pure C++ re-implementation of <pkg>app-text/hunspell</pkg>.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">nuspell/nuspell</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/nuspell/nuspell-5.1.3.ebuild b/app-text/nuspell/nuspell-5.1.3.ebuild
new file mode 100644
index 000000000000..18d0806fde8f
--- /dev/null
+++ b/app-text/nuspell/nuspell-5.1.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/5" # due to libnuspell.so.5
+KEYWORDS="amd64 ~loong ~riscv x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/icu-60"
+DEPEND="${RDEPEND}
+ doc? ( virtual/pandoc )
+ test? ( <dev-cpp/catch-3:0 )
+ "
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ if ! use test ; then
+ rm -R external/hunspell/ || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users .'
+ einfo
+}
diff --git a/app-text/nuspell/nuspell-5.1.4.ebuild b/app-text/nuspell/nuspell-5.1.4.ebuild
new file mode 100644
index 000000000000..d0791bda1ad5
--- /dev/null
+++ b/app-text/nuspell/nuspell-5.1.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/5" # due to libnuspell.so.5
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/icu-60"
+DEPEND="${RDEPEND}
+ doc? ( virtual/pandoc )
+ test? ( >=dev-cpp/catch-3.1.1:0 )
+ "
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ if ! use test ; then
+ rm -R external/hunspell/ || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users .'
+ einfo
+}