summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ocrad/ocrad-0.27.ebuild')
-rw-r--r--app-text/ocrad/ocrad-0.27.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/ocrad/ocrad-0.27.ebuild b/app-text/ocrad/ocrad-0.27.ebuild
new file mode 100644
index 000000000000..2dba77c125e6
--- /dev/null
+++ b/app-text/ocrad/ocrad-0.27.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker toolchain-funcs
+
+DESCRIPTION="GNU Ocrad is an OCR (Optical Character Recognition) program"
+HOMEPAGE="https://www.gnu.org/software/ocrad/ocrad.html"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="$(unpacker_src_uri_depends)"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ # ./configure is not based on autotools
+ ./configure \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ --prefix=/usr || die
+}
+
+src_install() {
+ default
+ doman doc/${PN}.1
+ doinfo doc/${PN}.info
+}