summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pandoc-cli')
-rw-r--r--app-text/pandoc-cli/Manifest1
-rw-r--r--app-text/pandoc-cli/metadata.xml18
-rw-r--r--app-text/pandoc-cli/pandoc-cli-0.1.1-r1.ebuild40
3 files changed, 59 insertions, 0 deletions
diff --git a/app-text/pandoc-cli/Manifest b/app-text/pandoc-cli/Manifest
new file mode 100644
index 000000000000..7723b3414780
--- /dev/null
+++ b/app-text/pandoc-cli/Manifest
@@ -0,0 +1 @@
+DIST pandoc-cli-0.1.1.tar.gz 10814 BLAKE2B 22ecd904a5e8222f68ef5b72c343a6e87448a8f4839092bca0291864cd34389061119223296171447c1570a1667e9257661ec71bbb9acffe4406ccee7dd67181 SHA512 bf05834761d9c78a21b5aaf20a3a1ca24e035e394e22858506d649ec669d8ca72d8578ad9ba2e4d24bc1681dc8faa9e4c1a39fa1d82414da51e6786b23f31a36
diff --git a/app-text/pandoc-cli/metadata.xml b/app-text/pandoc-cli/metadata.xml
new file mode 100644
index 000000000000..14cb3430e380
--- /dev/null
+++ b/app-text/pandoc-cli/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="lua">Support custom modifications and conversions with the
+pandoc Lua scripting engine.</flag>
+ <flag name="nightly">Add &#39;-nightly-COMPILEDATE&#39; to the output of &#39;--version&#39;.</flag>
+ <flag name="server">Include support for running pandoc as an HTTP server.</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">pandoc-cli</remote-id>
+ <remote-id type="github">jgm/pandoc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/pandoc-cli/pandoc-cli-0.1.1-r1.ebuild b/app-text/pandoc-cli/pandoc-cli-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..cc0245832715
--- /dev/null
+++ b/app-text/pandoc-cli/pandoc-cli-0.1.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES=""
+inherit haskell-cabal
+
+DESCRIPTION="Conversion between documentation formats"
+HOMEPAGE="https://pandoc.org"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+lua nightly +server"
+
+RDEPEND=">=dev-haskell/pandoc-3.0:=
+ dev-haskell/text:=
+ >=dev-lang/ghc-8.8.1:=
+ lua? ( >=dev-haskell/hslua-cli-1.4.1:= <dev-haskell/hslua-cli-1.5:=
+ >=dev-haskell/pandoc-lua-engine-0.2:= <dev-haskell/pandoc-lua-engine-0.3:=
+ >=dev-haskell/temporary-1.1:= <dev-haskell/temporary-1.4:= )
+ server? ( >=dev-haskell/pandoc-server-0.1:= <dev-haskell/pandoc-server-0.2:=
+ dev-haskell/safe:=
+ >=dev-haskell/wai-extra-3.0.24:=
+ dev-haskell/warp:= )
+ !<app-text/pandoc-3
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lua lua) \
+ $(cabal_flag nightly nightly) \
+ $(cabal_flag server server)
+}