summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/passivetex/passivetex-1.25-r1.ebuild')
-rw-r--r--app-text/passivetex/passivetex-1.25-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/passivetex/passivetex-1.25-r1.ebuild b/app-text/passivetex/passivetex-1.25-r1.ebuild
new file mode 100644
index 000000000000..d0aa4bc6536e
--- /dev/null
+++ b/app-text/passivetex/passivetex-1.25-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit latex-package
+
+DESCRIPTION="A namespace-aware XML parser written in Tex"
+HOMEPAGE="http://www.tei-c.org.uk/Software/passivetex/"
+# Taken from: http://www.tei-c.org.uk/Software/passivetex/${PN}.zip
+SRC_URI="mirror://gentoo/${P}.zip"
+S=${WORKDIR}/${PN}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+ >=dev-tex/xmltex-1.9"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+TEXMF=/usr/share/texmf-site
+
+src_install() {
+ insinto ${TEXMF}/tex/xmltex/passivetex
+ doins *.sty *.xmt
+
+ dodoc README.passivetex index.{html,xml}
+}