summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pastebinit')
-rw-r--r--app-text/pastebinit/Manifest2
-rw-r--r--app-text/pastebinit/metadata.xml14
-rw-r--r--app-text/pastebinit/pastebinit-1.3.1-r2.ebuild56
-rw-r--r--app-text/pastebinit/pastebinit-1.4.1.ebuild59
4 files changed, 131 insertions, 0 deletions
diff --git a/app-text/pastebinit/Manifest b/app-text/pastebinit/Manifest
new file mode 100644
index 000000000000..2504a0060d23
--- /dev/null
+++ b/app-text/pastebinit/Manifest
@@ -0,0 +1,2 @@
+DIST pastebinit-1.3.1.tar.bz2 35582 SHA256 0dcb6c4820f49cc7f97a7804254df1ae848cfc4fc63e08ca89a525b909709e29 SHA512 f9c4eafbe194dc7fe85ae37005846c38fe9863ed18406953fa6974d979592d74a01eba4dfde3e91da121d36355d87fd2464b565d0eb6aa0091b2b338989567bf WHIRLPOOL 42c58f5cad96361c7f254a17db5a14304ec523b1a50548f27c0a77336e9384f971267a753c1fbc538301dee6cd1d228333976d96618dec8d33539a3e85771525
+DIST pastebinit-1.4.1.tar.bz2 39202 SHA256 c23720ff19d239f7ae62dd7dc28f453aaea4823af29b1595ba2e58fe232988e6 SHA512 40cfdc22a9d168b239c799ecefca8b9a4f873edeb868803d8de4e57b291f695b9aa3f0b04d87b29ca1777917a53f0c210f20fa8661673630e9a29331e10dc065 WHIRLPOOL 49425b36db3477cd141eee676aa256c8d65567c189dd2cf90bfc53a29824f9611f5d9e54d1d470fdd747bacf141198fe49df7c25c83c96c98da85e3026af3056
diff --git a/app-text/pastebinit/metadata.xml b/app-text/pastebinit/metadata.xml
new file mode 100644
index 000000000000..87d7228d29dc
--- /dev/null
+++ b/app-text/pastebinit/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+ <use>
+ <flag name="crypt">Install pbputs for gpg-encrypted pastes</flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">pastebinit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/pastebinit/pastebinit-1.3.1-r2.ebuild b/app-text/pastebinit/pastebinit-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..30eee6fde197
--- /dev/null
+++ b/app-text/pastebinit/pastebinit-1.3.1-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1
+
+DESCRIPTION="A software that lets you send anything you want directly to a
+pastebin from the command line."
+HOMEPAGE="https://launchpad.net/pastebinit"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="crypt"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/configobj[${PYTHON_USEDEP}]
+ crypt? ( app-crypt/gnupg )"
+DEPEND="app-text/docbook-xsl-stylesheets"
+
+src_prepare() {
+ local mo=""
+
+ for lang in ${LINGUAS}; do
+ if [ -f po/${lang}.po ]; then
+ mo="${mo} ${lang}.mo"
+ fi
+ done
+
+ sed -i -e "/^build-mo/s/:.*/:${mo}/" po/Makefile
+}
+
+src_compile() {
+ emake -C po
+ xsltproc --nonet \
+ "${EROOT}"usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl \
+ pastebinit.xml || die
+}
+
+src_install() {
+ dobin pastebinit utils/pbput
+ python_replicate_script "${ED}usr/bin/${PN}"
+ dosym pbput /usr/bin/pbget
+ use crypt && dosym pbput /usr/bin/pbputs
+ dodoc README
+ doman pastebinit.1 utils/*.1
+ insinto /usr/share/locale
+ [[ -d po/mo ]] && doins -r po/mo/*
+ insinto /usr/share
+ doins -r pastebin.d
+}
diff --git a/app-text/pastebinit/pastebinit-1.4.1.ebuild b/app-text/pastebinit/pastebinit-1.4.1.ebuild
new file mode 100644
index 000000000000..8abca4fa4293
--- /dev/null
+++ b/app-text/pastebinit/pastebinit-1.4.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="xml"
+
+inherit python-single-r1
+
+DESCRIPTION="A software that lets you send anything you want directly to a
+pastebin from the command line."
+HOMEPAGE="https://launchpad.net/pastebinit"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="crypt"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/configobj[${PYTHON_USEDEP}]
+ crypt? ( app-crypt/gnupg )"
+DEPEND="app-text/docbook-xsl-stylesheets"
+
+src_prepare() {
+ local mo=""
+
+ for lang in ${LINGUAS}; do
+ if [ -f po/${lang}.po ]; then
+ mo="${mo} ${lang}.mo"
+ fi
+ done
+
+ sed -i -e "/^build-mo/s/:.*/:${mo}/" po/Makefile || die
+ sed -i -e "/#!/s/python3/python/" pastebinit || die
+}
+
+src_compile() {
+ emake -C po
+ xsltproc --nonet \
+ "${EROOT}"usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl \
+ pastebinit.xml || die
+}
+
+src_install() {
+ dobin pastebinit utils/pbput
+ python_fix_shebang "${ED}usr/bin/${PN}"
+ dosym pbput /usr/bin/pbget
+ use crypt && dosym pbput /usr/bin/pbputs
+ dodoc README
+ doman pastebinit.1 utils/*.1
+ insinto /usr/share/locale
+ [[ -d po/mo ]] && doins -r po/mo/*
+ insinto /usr/share
+ doins -r pastebin.d
+}