summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pep/pep-2.8-r2.ebuild')
-rw-r--r--app-text/pep/pep-2.8-r2.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-text/pep/pep-2.8-r2.ebuild b/app-text/pep/pep-2.8-r2.ebuild
index f1864940b8b8..6ef0fb385c28 100644
--- a/app-text/pep/pep-2.8-r2.ebuild
+++ b/app-text/pep/pep-2.8-r2.ebuild
@@ -1,31 +1,32 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs flag-o-matic
DESCRIPTION="General purpose filter and file cleaning program"
HOMEPAGE="https://hannemyr.com/enjoy/pep.html"
SRC_URI="https://hannemyr.com/enjoy/${PN}${PV//./}.zip -> ${P}.zip"
+S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~mips ppc x86 ~x86-linux ~ppc-macos"
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
-S=${WORKDIR}
-
-# pep does not come with autconf so here's a patch to configure
+# pep does not come with autoconf so here's a patch to configure
# Makefile with the correct path
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-include.patch
+ "${FILESDIR}"/${P}-Fix-Wimplicit-int.patch
)
src_prepare() {
default
+
# Darwin lacks stricmp and DIRCHAR
if [[ ${CHOST} == *-darwin* ]] ; then
sed -i -e '/^OBJS/s/^\(.*\)$/\1 bdmg.o/' Makefile || die
@@ -35,7 +36,7 @@ src_prepare() {
src_compile() {
# make man page too
- make Doc/pep.1 || die "make man page failed"
+ emake Doc/pep.1
emake CC="$(tc-getCC)"
}