summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/poppler/poppler-0.84.0.ebuild')
-rw-r--r--app-text/poppler/poppler-0.84.0.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-text/poppler/poppler-0.84.0.ebuild b/app-text/poppler/poppler-0.84.0.ebuild
index 12fe62839eb5..dc4ab8ebb00d 100644
--- a/app-text/poppler/poppler-0.84.0.ebuild
+++ b/app-text/poppler/poppler-0.84.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils toolchain-funcs xdg-utils
+inherit cmake toolchain-funcs xdg-utils
if [[ ${PV} == *9999* ]] ; then
inherit git-r3
@@ -65,7 +65,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Clang doesn't grok this flag, the configure nicely tests that, but
# cmake just uses it, so remove it if we use clang
@@ -101,17 +101,17 @@ src_configure() {
-DENABLE_CMS=$(usex lcms lcms2 none)
-DWITH_NSS3=$(usex nss)
-DWITH_PNG=$(usex png)
- $(cmake-utils_use_find_package qt5 Qt5Core)
+ $(cmake_use_find_package qt5 Qt5Core)
-DWITH_TIFF=$(usex tiff)
-DENABLE_UTILS=$(usex utils)
)
use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# live version doesn't provide html documentation
if use cairo && use doc && [[ ${PV} != *9999* ]]; then