summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild')
-rw-r--r--app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild b/app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild
new file mode 100644
index 000000000000..7ad46cf8b162
--- /dev/null
+++ b/app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tool that converts a PostScript type1 font into a corresponding TeX PK font"
+HOMEPAGE="http://tug.org/texlive/"
+SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~mips ppc ~ppc64 ~s390 ~sh x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=">=dev-libs/kpathsea-6.2.0"
+RDEPEND="
+ !<app-text/texlive-core-2010
+ !app-text/ptex
+ ${DEPEND}"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
+DOCS=( "ChangeLog" "CHANGES.type1" "README" "README.14m" "README.type1" )
+
+src_configure() {
+ has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ econf --with-system-kpathsea
+}