summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/psmark/psmark-2.1.ebuild')
-rw-r--r--app-text/psmark/psmark-2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/psmark/psmark-2.1.ebuild b/app-text/psmark/psmark-2.1.ebuild
new file mode 100644
index 000000000000..8d8d4e7fd704
--- /dev/null
+++ b/app-text/psmark/psmark-2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PN=${PN}-v
+MY_P=${MY_PN}${PV}
+
+DESCRIPTION="Prints watermark-like text on any PostScript document"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://www.antitachyon.com/download/${MY_P}.tar.gz"
+S="${WORKDIR}"/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-string.patch
+ "${FILESDIR}"/${P}-Makefile-QA.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin psmark
+ doman psmark.1
+ dodoc README CHANGELOG
+}