summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pspresent/pspresent-1.3-r2.ebuild')
-rw-r--r--app-text/pspresent/pspresent-1.3-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/pspresent/pspresent-1.3-r2.ebuild b/app-text/pspresent/pspresent-1.3-r2.ebuild
new file mode 100644
index 000000000000..167d8e647c8a
--- /dev/null
+++ b/app-text/pspresent/pspresent-1.3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool to display full-screen PostScript presentations"
+HOMEPAGE="http://www.cse.unsw.edu.au/~matthewc/pspresent/"
+SRC_URI="http://www.cse.unsw.edu.au/~matthewc/pspresent/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="xinerama"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+ use xinerama && export USE_XINERAMA=1
+}
+
+src_install() {
+ dobin pspresent
+ doman pspresent.1
+}