summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/restview/restview-2.9.2.ebuild')
-rw-r--r--app-text/restview/restview-2.9.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/restview/restview-2.9.2.ebuild b/app-text/restview/restview-2.9.2.ebuild
new file mode 100644
index 000000000000..01d1f9c130b6
--- /dev/null
+++ b/app-text/restview/restview-2.9.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="reStructuredText viewer"
+HOMEPAGE="https://mg.pov.lt/restview/ https://pypi.org/project/restview/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/readme_renderer[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGES.rst )
+
+python_test() {
+ esetup.py test
+}