summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/rman/rman-3.2-r1.ebuild')
-rw-r--r--app-text/rman/rman-3.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/rman/rman-3.2-r1.ebuild b/app-text/rman/rman-3.2-r1.ebuild
new file mode 100644
index 000000000000..7e675184546b
--- /dev/null
+++ b/app-text/rman/rman-3.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="PolyGlotMan man page translator AKA RosettaMan"
+HOMEPAGE="http://sourceforge.net/projects/polyglotman/"
+SRC_URI="mirror://sourceforge/polyglotman/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.diff \
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-format-security.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}