summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/rman/rman-3.2-r2.ebuild')
-rw-r--r--app-text/rman/rman-3.2-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/rman/rman-3.2-r2.ebuild b/app-text/rman/rman-3.2-r2.ebuild
new file mode 100644
index 000000000000..89aa667137fd
--- /dev/null
+++ b/app-text/rman/rman-3.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="PolyGlotMan man page translator AKA RosettaMan"
+HOMEPAGE="https://sourceforge.net/projects/polyglotman/"
+SRC_URI="https://downloads.sourceforge.net/polyglotman/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-incompatible-pointer-types.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}