summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/rnc2rng/rnc2rng-2.6.6-r3.ebuild')
-rw-r--r--app-text/rnc2rng/rnc2rng-2.6.6-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-text/rnc2rng/rnc2rng-2.6.6-r3.ebuild b/app-text/rnc2rng/rnc2rng-2.6.6-r3.ebuild
new file mode 100644
index 000000000000..6128abda57bf
--- /dev/null
+++ b/app-text/rnc2rng/rnc2rng-2.6.6-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11,12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="RELAX NG Compact to regular syntax conversion library"
+HOMEPAGE="https://github.com/djc/rnc2rng"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/rply[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_test() {
+ "${EPYTHON}" test.py -v || die "Tests failed with ${EPYTHON}"
+}