summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/rtf2html/rtf2html-0.2.0-r1.ebuild')
-rw-r--r--app-text/rtf2html/rtf2html-0.2.0-r1.ebuild25
1 files changed, 6 insertions, 19 deletions
diff --git a/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild b/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
index d5f0c353c4c1..09aa4b9a8dd4 100644
--- a/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
+++ b/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
@@ -1,34 +1,21 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
-
-inherit base flag-o-matic
+EAPI=7
DESCRIPTION="RTF to HTML converter"
HOMEPAGE="http://rtf2html.sourceforge.net/"
-SRC_URI="mirror://sourceforge/rtf2html/${P}.tar.bz2"
+SRC_URI="https://downloads.sourceforge.net/rtf2html/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-DOCS=( ChangeLog README )
-
-PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+PATCHES=( "${FILESDIR}"/${P}-gcc43.patch )
src_prepare() {
+ default
+
# CFLAGS are incorrectly parsed, so handle this here
sed -i -e '/CFLAGS=$(echo $CFLAGS/d' configure || die 'sed on configure failed'
- use !debug && filter-flags "-g*"
-
- base_src_prepare
-}
-
-src_configure() {
- econf $(use_enable debug)
}