summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/rtf2html/rtf2html-0.2.0-r1.ebuild')
-rw-r--r--app-text/rtf2html/rtf2html-0.2.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild b/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..3199bdae8125
--- /dev/null
+++ b/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit base flag-o-matic
+
+DESCRIPTION="RTF to HTML converter"
+HOMEPAGE="http://rtf2html.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rtf2html/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog README )
+
+PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+
+src_prepare() {
+ # CFLAGS are incorrectly parsed, so handle this here
+ sed -i -e '/CFLAGS=$(echo $CFLAGS/d' configure || die 'sed on configure failed'
+ use !debug && filter-flags "-g*"
+
+ base_src_prepare
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}