summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/sablotron')
-rw-r--r--app-text/sablotron/files/sablotron-1.0.3-cxx11.patch11
-rw-r--r--app-text/sablotron/files/sablotron-1.0.3-drop-register-keyword.patch14
-rw-r--r--app-text/sablotron/files/sablotron-1.0.3-libsablot-expat.patch (renamed from app-text/sablotron/files/1.0.3-libsablot-expat.patch)6
-rw-r--r--app-text/sablotron/metadata.xml7
-rw-r--r--app-text/sablotron/sablotron-1.0.3-r1.ebuild44
-rw-r--r--app-text/sablotron/sablotron-1.0.3-r2.ebuild56
-rw-r--r--app-text/sablotron/sablotron-1.0.3-r3.ebuild51
7 files changed, 139 insertions, 50 deletions
diff --git a/app-text/sablotron/files/sablotron-1.0.3-cxx11.patch b/app-text/sablotron/files/sablotron-1.0.3-cxx11.patch
new file mode 100644
index 000000000000..edc1e3141d94
--- /dev/null
+++ b/app-text/sablotron/files/sablotron-1.0.3-cxx11.patch
@@ -0,0 +1,11 @@
+--- a/src/command/sabcmd.cpp
++++ b/src/command/sabcmd.cpp
+@@ -168,7 +168,7 @@
+
+ char askhelp[] = "Type sabcmd --help to display a help message.\n";
+ char msgConflict[] = "conflict with preceding switches: ";
+-char version_txt[] = "\nsabcmd "SAB_VERSION" ("SAB_DATE")\n"\
++char version_txt[] = "\nsabcmd " SAB_VERSION " (" SAB_DATE ")\n"\
+ "copyright (C) 2000 - 2005 Ginger Alliance (www.gingerall.com)\n";
+ char dbg_usage[] = "\nDebugging options:\n"\
+ "\t--debug\t\t\tdisplay results of the command line parse\n"\
diff --git a/app-text/sablotron/files/sablotron-1.0.3-drop-register-keyword.patch b/app-text/sablotron/files/sablotron-1.0.3-drop-register-keyword.patch
new file mode 100644
index 000000000000..3dcf8c881efa
--- /dev/null
+++ b/app-text/sablotron/files/sablotron-1.0.3-drop-register-keyword.patch
@@ -0,0 +1,14 @@
+Bug: https://bugs.gentoo.org/894710
+--- a/src/engine/hash.cpp
++++ b/src/engine/hash.cpp
+@@ -305,8 +305,8 @@ void HashTable::report(Sit S, MsgType type, MsgCode code, const Str& arg1, const
+
+ oolong hash(const Str& key)
+ {
+- register oolong a, b, c, len;
+- register const char *k = (const char*) key;
++ oolong a, b, c, len;
++ const char *k = (const char*) key;
+
+ /* Set up the internal state */
+ len = key.length();
diff --git a/app-text/sablotron/files/1.0.3-libsablot-expat.patch b/app-text/sablotron/files/sablotron-1.0.3-libsablot-expat.patch
index 328c9e906856..614a6d7ffe24 100644
--- a/app-text/sablotron/files/1.0.3-libsablot-expat.patch
+++ b/app-text/sablotron/files/sablotron-1.0.3-libsablot-expat.patch
@@ -1,10 +1,8 @@
-diff --git a/src/engine/Makefile.am b/src/engine/Makefile.am
-index abd2041..1307b1c 100644
--- a/src/engine/Makefile.am
+++ b/src/engine/Makefile.am
@@ -76,4 +76,5 @@ include_HEADERS = \
sabcfg.h
-
+
libsablot_la_LDFLAGS = -version-info 100:3:100
+libsablot_la_LIBADD = @EXPAT_LIBS@
-
+
diff --git a/app-text/sablotron/metadata.xml b/app-text/sablotron/metadata.xml
index 6f49eba8f496..5e2c2974f79d 100644
--- a/app-text/sablotron/metadata.xml
+++ b/app-text/sablotron/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">sablotron</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-text/sablotron/sablotron-1.0.3-r1.ebuild b/app-text/sablotron/sablotron-1.0.3-r1.ebuild
deleted file mode 100644
index 622e9320de00..000000000000
--- a/app-text/sablotron/sablotron-1.0.3-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-MY_PN="Sablot"
-MY_P="${MY_PN}-${PV}"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="An XSLT Parser in C++"
-HOMEPAGE="http://www.gingerall.org/sablotron.html"
-SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"
-
-# Sablotron can optionally be built under GPL, using MPL for now
-LICENSE="MPL-1.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="perl"
-
-RDEPEND=">=dev-libs/expat-1.95.6-r1"
-DEPEND="${RDEPEND}
- >=dev-perl/XML-Parser-2.3"
-
-PATCHES=( "${FILESDIR}/1.0.3-libsablot-expat.patch" )
-
-src_prepare() {
- default
- sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
- eautoreconf
- elibtoolize
-}
-
-src_configure() {
- econf \
- $(use_enable perl perlconnect) \
- --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc README README_JS RELEASE src/TODO
-}
diff --git a/app-text/sablotron/sablotron-1.0.3-r2.ebuild b/app-text/sablotron/sablotron-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..6492100a9034
--- /dev/null
+++ b/app-text/sablotron/sablotron-1.0.3-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PN="Sablot"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="An XSLT Parser in C++"
+HOMEPAGE="https://sourceforge.net/projects/sablotron/"
+SRC_URI="https://downloads.sourceforge.net/sablotron/${MY_P}.tar.gz"
+
+# Sablotron can optionally be built under GPL, using MPL for now
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="perl"
+
+RDEPEND="
+ >=dev-libs/expat-1.95.6-r1
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ >=dev-perl/XML-Parser-2.3
+"
+DOCS=(
+ README README_JS RELEASE src/TODO
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3-libsablot-expat.patch
+ "${FILESDIR}"/${PN}-1.0.3-cxx11.patch
+)
+
+src_prepare() {
+ default
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable perl perlconnect) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/app-text/sablotron/sablotron-1.0.3-r3.ebuild b/app-text/sablotron/sablotron-1.0.3-r3.ebuild
new file mode 100644
index 000000000000..9d99cace3876
--- /dev/null
+++ b/app-text/sablotron/sablotron-1.0.3-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P="Sablot-${PV}"
+
+DESCRIPTION="An XSLT Parser in C++"
+HOMEPAGE="https://sourceforge.net/projects/sablotron/"
+SRC_URI="https://downloads.sourceforge.net/sablotron/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+# Sablotron can optionally be built under GPL, using MPL for now
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="perl"
+
+DEPEND=">=dev-libs/expat-1.95.6-r1"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-perl/XML-Parser-2.3"
+
+DOCS=( README README_JS RELEASE src/TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3-libsablot-expat.patch
+ "${FILESDIR}"/${PN}-1.0.3-cxx11.patch
+ "${FILESDIR}"/${PN}-1.0.3-drop-register-keyword.patch
+)
+
+src_prepare() {
+ default
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable perl perlconnect)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}