summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/silvercity/silvercity-0.9.7-r1.ebuild')
-rw-r--r--app-text/silvercity/silvercity-0.9.7-r1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/app-text/silvercity/silvercity-0.9.7-r1.ebuild b/app-text/silvercity/silvercity-0.9.7-r1.ebuild
deleted file mode 100644
index 29e26f3f30bf..000000000000
--- a/app-text/silvercity/silvercity-0.9.7-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils
-
-MY_PN="SilverCity"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A lexical analyser for many languages"
-HOMEPAGE="http://silvercity.sourceforge.net/"
-SRC_URI="mirror://sourceforge/silvercity/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ia64 ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Fix line endings.
- find -type f -exec sed -e 's/\r$//' -i {} + || die "sed failed"
-
- # Fix permissions.
- chmod -x CSS/default.css || die "chmod failed"
-
- # Fix shebang.
- sed -e 's:#!/usr/home/sweetapp/bin/python:#!/usr/bin/env python:' \
- -i PySilverCity/Scripts/cgi-styler-form.py || die "sed failed"
-
- distutils-r1_python_prepare_all
-}