summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/spellutils/spellutils-0.7.ebuild')
-rw-r--r--app-text/spellutils/spellutils-0.7.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/app-text/spellutils/spellutils-0.7.ebuild b/app-text/spellutils/spellutils-0.7.ebuild
index 1c371d0dc919..36331975124e 100644
--- a/app-text/spellutils/spellutils-0.7.ebuild
+++ b/app-text/spellutils/spellutils-0.7.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="spellutils includes 'newsbody' (useful for spellchecking in mails, etc.)"
HOMEPAGE="http://home.worldonline.dk/byrial/spellutils/"
@@ -10,21 +11,18 @@ SRC_URI="http://home.worldonline.dk/byrial/spellutils/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ~mips ppc ~sparc x86"
+KEYWORDS="~alpha amd64 ~hppa ~mips ppc ~sparc x86"
IUSE="nls"
-DEPEND="
- nls? ( sys-devel/gettext )
-"
-DEPEND="
- nls? ( virtual/libintl )
-"
+DEPEND="nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
DOCS=( NEWS README )
-src_prepare() {
- epatch "${FILESDIR}"/${P}-nls.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-nls.patch
+)
src_configure() {
econf $(use_enable nls)