summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/tkinfo/tkinfo-2.8-r2.ebuild')
-rw-r--r--app-text/tkinfo/tkinfo-2.8-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/tkinfo/tkinfo-2.8-r2.ebuild b/app-text/tkinfo/tkinfo-2.8-r2.ebuild
new file mode 100644
index 000000000000..97256a448ef4
--- /dev/null
+++ b/app-text/tkinfo/tkinfo-2.8-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Info Browser in TK"
+HOMEPAGE="http://math-www.uni-paderborn.de/~axel/tkinfo/"
+SRC_URI="http://math-www.uni-paderborn.de/~axel/${PN}/${P}.tar.gz"
+
+LICENSE="Old-MIT GPL-1+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc sparc x86"
+
+RDEPEND="dev-lang/tk"
+
+src_prepare() {
+ default
+ sed -e "1 s:^.*:#!/usr/bin/env wish:" \
+ -i tkinfo || die "sed tkinfo failed"
+}
+
+src_install() {
+ dobin tkinfo
+ doman tkinfo.1
+}