summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ttf2pk2/ttf2pk2-2.0_p20210325.ebuild')
-rw-r--r--app-text/ttf2pk2/ttf2pk2-2.0_p20210325.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/ttf2pk2/ttf2pk2-2.0_p20210325.ebuild b/app-text/ttf2pk2/ttf2pk2-2.0_p20210325.ebuild
new file mode 100644
index 000000000000..a6a15aa046a2
--- /dev/null
+++ b/app-text/ttf2pk2/ttf2pk2-2.0_p20210325.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Freetype 2 based TrueType font to TeX's PK format converter"
+HOMEPAGE="https://tug.org/texlive/"
+SRC_URI="https://dev.gentoo.org/~sam/texlive/texlive-${PV#*_p}-source.tar.xz"
+S="${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# Note about blockers: it is a freetype2 based replacement for ttf2pk and
+# ttf2tfm from freetype1, so block freetype1.
+# It installs some data that collides with
+# dev-texlive/texlive-langcjk-2011[source]. Hope it'd be fixed with 2012,
+# meanwhile we can start dropping freetype1.
+RDEPEND=">=dev-libs/kpathsea-6.2.1
+ media-libs/freetype:2
+ sys-libs/zlib
+ !media-libs/freetype:1"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf --with-system-kpathsea \
+ --with-system-freetype2 \
+ --with-system-zlib
+}